Extremely poor multibox performance since DX12 patch

Hi

Let me preface this by saying I do not use the DX12 client, it is in a really bad state, it causes constant and consistent issues for me, and I really do not think it is a good idea to have everyone’s client defaulting to that, as some newbro is going to come along, see the state of the DX12 client, and never play the game again. On to my issue…

Ever since the DX12 patch I have had poor performance whilst multiboxing, especially when I do things like conduit jumping a fleet of ships to another system. It takes quite a bit of time for the clients to become responsive again after making the jump, and takes some time for them all to load in things like citadel or station models. This did not happen before the DX12 client patch. I have not changed any of my hardware. I have reinstalled the game twice, I have cleared my cache, I have updated all my drivers, it makes no difference.

I don’t run the game in DX12 at all because when I run the game in DX12 I will get black screens on all monitors within about 5-10 minutes in a typical session. It is unusable for me. My GPU is from 2019, but it’s whatever, I just play the game in DX11 mode.

Before the DX12 patch, I could easily multibox 20 clients, no problem. No issues mass jumping through gates, no issues taking titan bridges or conduit jumps. Now, if I’m running more than 3-4 clients, all of my clients will lock up for a solid 5-20 seconds after taking those actions whilst the game gets around to loading the grid. It was flawless before the DX12 update was released. I also suffer worse performance in general with lower framerates than before, and my PC has now decided that 30 or so characters worth of drones (150) on the grid is now a bad thing for my framerate. Again, this was perfectly fine before. No settings changes, no hardware changes. Only change is the EVE version.

Anyone else having similar issues? Some of my corp are saying the same, they are having trouble multiboxing more than 2-4 clients. DX12 is definitely an issue but even with it disabled (which does improve things) it’s still bad, and some of us are unable to multibox an amount of accounts that worked just fine before.

1 Like

Yes. It has been terrible since the update, and I do not have DX12 enabled either. No issues multiboxing prior to the client update, nonstop issues ever since.

Gating in to a system leads to an extended load time, which makes cloak+MWD on, say, a DST something of a problem. Undocking in Jita, the screen stays black, or the skybox comes up but nothing else loads for a while. By the time everything is loaded and controls are responsive, my ship is 20+ km off the undock. This happens regardless of number of clients running. I can have a single client running and the grid load issue persists.

Three days ago, I undocked a DST in Jita, highlighted the out gate in overview, then clicked on the “Jump” button. As soon as I clicked on the “Jump” button, the selected object magically switched from the out gate to a different station in system, and the “Jump” button magically became “Dock.”

I immediately hit CTRL+SPACE and received the “Ship Stopping” pop up. I then highlighted the out gate in overview again, clicked “Jump” again and received a popup that I can’t do that while warping. My ship then warped to the previously, magically selected station, but did not dock (presumably the CTRL+SPACE event kicked in). By this time, everything on grid had loaded and I was able to warp from that station to the out gate just fine. Of course, then I jumped the gate and the next system took 10-15 seconds to load grid.

When jumping through a wormhole, the grid load time causes a right click > save location to be interpreted as either “show info,” or behave like I clicked in dead space, disabling the right click context menu altogether. This happens about 50% of the time.

It’s aggravating and irritating, especially considering, with the same hardware and configuration, I had zero lag issues before they updated the client. All drivers are current and my system (custom built by me) is only a couple of years old. Enabling DX12 makes the game even more unplayable.

All of my accounts expire at the end of the year. With the current state of both the client and the game, I’m not inclined to renew. Reading the Known Issues for today’s update doesn’t give me reason to believe it’s going to improve, but I guess we’ll see.

2 Likes

Yeah, there’s been a decent number of people complaining. I’ve heard some possible solutions, but the only thing that worked for me was disabling DX12.

I run multiple accounts on DX12 at 4k with graphics maxed out and have no issues. Sucks for those who do, but I suspect it’s as much user fault as it is CCPs’. For instance, running a potato means you shouldn’t even be trying DX12 on any game, much less EvE. Oh, and “MY PC supports DX12! Windows says so!”. No, just because your OS supports DX12 does not mean your PC does. Not saying this is those posting here, just saying I’ve seen these people crying when DX9 was here (OMG WE HAVE TO HAVE GPU’s?!?) , when DX10 was here, when DX11, was here, and now with DX12. Unfortunately, the “average” PC user has no technical knowledge outside of pushing the power button ( many can’t even accomplish that without issues which is why you have tech support asking if your PC is plugged in because, well, these people are the average ) and thus thinks because they could run a game in the last DX iteration, they automatically should be able to run the same game in the current one with no issues.

Typically I don’t use the latest DX version, simply because these issues of “the new DX has more problems than the old one” has been a recurring issue from Microsoft and developers since DX9.

It seems to take a couple years until everything settles down, both on the developer side and on the “user configuration” end.

My own system is Ryzen 7 2700X, GEForce RTX 2070, 32GB Ram. Not high end but not a potato either. With DX11 things run mostly smoothly, with some stutter and pausing, mostly on undocking or the occasional gate exit. With a fairly rare “undocking gives a black screen fo 15 seconds or so until EVE figures out where I am” delay.

With DX12 turned on, the first few undocks and gate jumps of the day are very slow and very chunky/laggy/pausing. It appears to improve over time. I don’t multibox or multi-monitor - single screen, full screen, at 1920x1080. Graphics aren’t even all set to High, some are medium and shadows are off.

Some people found limiting frame rate or VSync to help:

If I find any other tips I’ll post them here.