Flickering since Nvidia 526.86 driver

Since the 526.86 driver update seen lots of flickering with shadows on ships and planet customs offices and various structures, not sure if it’s a CCP issue as going back to the 522.25 driver fixes the issue.


You might try deleting nvidia shader cache


Try running EVE in directx11 instead of 12 in the launcher, worked for me, but I’m not sure it’s the right solution, because we should be able to run eve in Directx12 without issues…

This is the flickering I am seeing in space and docked up around the inside of the station.
[Graphical Bug] EVE Texture/Light Flickering - YouTube
It happens in World of Warcraft as well. It seems to be related to “shader optimization” introduced a while back for Dx12. However, I don’t find “just use Dx11” (which does fix it, at least) as a proper solution as it’s a very outdated framework.

Another better workaround might include decreasing shader quality settings (or just swapping them back and forth). I haven’t tested this one yet thoroughly.
Uninstalling the Nvidia driver and re-installing a previous version might also work. This workaround is difficult though as it’s hard to pinpoint which exact version it occurs in.

Sadly, I don’t think this an “EVE problem” as it’s a Nvidia driver related issue where some kind of optimization is turned on that is quite buggy and affects multiple games. I could be wrong.

I should mention I am now on 526.98 and it still occurs. I have tried both game ready and studio ready drivers. I am using a RTX 3080 Nvidia card (but I don’t think that has anything to do with the issue).

I had the same Problem.
This fixed it:

  • Delete DXCache ( ‘%LocalAppData%\NVIDIA\DXCache’ or ‘%LocalAppData%\AMD\DXCache’)
  • Deactivate Steam Overlay
  • everoot\eve.exe → Properties → disable fullscreen optimization

edit: even dx12 works without problems now
edit2: nope, dx12 still glitches out

1 Like

I am having the same issue. Flickering of structures and ships but only when clicking on anything while undocked. Anyone know of a solid and tested fix for this?
No issues in other games for me though.

Amarr station interior is a pain, I get these darker flickering areas all the time, seems to be related to lighting

I’ve noticed the flickering increases if the application is out of focus, so possibly influenced by fps

EDIT: can confirm that reverting to DX11 fixed it, thank you all for saving me from epilepsy :stuck_out_tongue:

This is annoying. Hope this gets fixed soon.

I also have this issue, with Nvidia driver 526.98 in DX12. Setting Shadow Quality to Disabled seems to fix it, but that makes everything looks kinda cartoony so it’s not a great fix.

Hat the same issue even with an older Nvidia driver… switching to DX 11 solved it for me.

texture flickering, yes…
at the time of this writing Nvidia 522.30 driver is in use and flicker gliches occur with both DX12 and DX11 for me.
cache deletions and other troubleshooting suggestions, in short, do no good.

I have the same issue.
528.49 Nvidia Driver

same issue.
528.49 Nvidia Driver

Same issue

There have been a couple of NVIDIA driver updates since, but the issue still remains.

I have a RTX 2060 on Lenovo Legion just for info.

I too have this issue, did anyone create a ticket with Nvidia/CCP?

My issue seems to have resolved itself , not seen any flickering.

Latest nvida drivers used

Same issue. Unplayable in stations.

same issue

531.68 NVIDIA driver. The issue still persists.