FPS drop on unfocused client

Trying to use 2 clients on 2 x 4k monitors with a 1050Ti and an i72600k
I get 70fps on the focused client, but this drops to around 3-4fps when I focus on the other client and vice versa…

Both clients set to windowed mode, and I have read that this can cause the unfocused client to drop fps , so to use fixed windowed mode.

However, when I try, each client tries to use the same monitor, instead of 1 client per monitor, requiring Alt+teb to view each client, while 2nd monitor is empty.

Is there a way to have fixed windowed mode active for each client, while having 1 on one monitor and 1 on the other?

The only way I know is to have both clients in windowed mode, and drag one to the 2nd monitor, as I currently have, but then I get the fps drop on the unfocused client.

Have searched this subject and the fps drop seems to be quite common, and I have tried all fixes I could find other than this fixed windowed mode for each client (due to the clients both trying to use 1 monitor, as I stated).

Can anyone help?

Windows 11
Intel i7 2600k
512Gb SSD
1050Ti
Latest NVidea drivers
Latest drivers for whole PC.
2x 4k monitors, same resolution used on both.
Windows spanned desktop.

disable full screen optimization.

it’s some sort of windows feature that limit’s fps and/or resources on inactive clients. You can also try disable gaming mode

1 Like

Thanks for that. I already had gaming mode switched off. Ill try the other tweak.

EDIT!
PERFECT:

EDIT 2
Not so perfect :frowning: So, it does make both have around 50 dps, but only if in station and neither windows are focused (like, if I am focused on a browser window).

Any more ideas?

Has anybody found a solution to this issue?

2 Likes

Nope.
Although, if I turn my graphics to the lowest setting ingame, it maintains the fps for both screens. So maybe my graphics card just isnt powerful enough…

try this
in the launcher settings uncheck enable high dpi scaling.

1 Like

Tried all of the options mentioned above: Nothing helped.

EDIT: Updated Videocard driver, checked for win10 updates and installed them, did a filecheck of the shared cache: WORKS!

I would say this is due to the age of your GPU.

It’s not a bug, it is intended behavior by CCP. Open your FPS monitor and it will show you a status for “FPS Throttling”. Not something a Windows option or driver update is going to fix. What you need is a program that can force specific unfocused windows to remain active without taking input events from other windows. Unfortunately, ISBoxer is the only program able to do this.

If you end up getting it or have it already, the setting for this can be found under the General tab in your character set.
ISBoxer_Toolkit_IQD57uAjsS