Geforce Now is using the outdated launcher and Eve is now unplayable. Big oof! :(

Hey there,

I already contacted a GM about this through the support function, but i’d like to address the problem surrounding Geforce Now and Eve Online. GFN has not updated to the new launcher, meaning everyone using that service for Eve can no longer log in.

It would be nice if this gains some traction or attention, as the customer support for GFN is absolutely abysmal and it wouldn’t be the first time a game goes ‘offline’ in such a stealth manner for weeks, if not months. That would bleed the entire playerbase using the service, including yours truly!

Halp. :slight_smile:

1 Like

I would just download the launcher straight from CCP and not use a middle man (GFN/Steam/ETC) that just points to the same file location anyways.

1 Like

Heya, thanks for the reply!

Unfortunately GFN is a cloud streaming service that pre-selects the way games are launched and stored. I do not have access to their file management.

I (and many others) are using the service so they can enjoy Eve on their cheap potato spec computers (or in my case a macbook which really shouldn’t try opening games).

The problem here is that Nvidia’s GeForce Now redirects me to CCP to fix it, and upon contacting CCP i stumble upon a dead end pretty much.

Same issue here. Re-activated my account for the holidays, especially since there are some great packages currently available. Really frustrating that Geforce Now isn’t working and nobody seems to care about it. :frowning:

Fortunately, I found the following workaround: Start the game from the Steam library in Geforce Now, then it works.
You can then easily log into the account you want to play and are not limited to your Steam character.

Still, I hope that CCP fixes the actual problem soon!

1 Like

This is a steam update problem. CCP is aware and the update is being readied. Just wait it over.

CCP Shawarma has it under kontrol…

Why arent they deploying steam? They made new launcher mandatory for everyone else over a month ago

Steam probably wont approve it for security reasons

Unfortunately, it seems like all options are not working and it’s not 100% steam related. GFN just doesn’t work right now. There are 3 options to launch in GFN:

CCP - The (old) launcher loads the game files, you press play but nothing happens.

Epic Games Store - It uses the new launcher, but when you press ‘play’ it says the client is open, but you cannot access the game. It keeps you locked on the launcher.

Steam - The (old) launcher tries to download the game files, but crashes halfway through.

Ugh!

Download the new launcher from CCP and point it to the right location, if you have the game files in a cloud, just download the game, it’s not that big.

I came back to Eve for the holiday’s via GeForce Now, using my Pixelbook Go. It almost felt too good to be true.

Then the update happened and it was offline for days “Updating”. The workaround was to launch through Epic Games as that got updated first.

Now it’s down for maintenance across all three options and has been for a week now.

1 Like

Hate to say, this is still not playable…

It was updated and usable two days before Vanguard playtest started on January 25th. It ended today so I would wait 1-2 days and it should unlock

Unfortunately not the case, i was hopeful too. Considering the roadmap is set to push a playtest with updates for Vanguard monthly, i’m afraid the service will be completely unusable for the coming months.

Contact geforce. Ccp has no control over a 3rd party service

It can be CCP blocking requests from GFN because of Vanguard not being ready for it…

1 Like

I have done so a lot of times, and unfortunately their customer service is absolutely dreadful. You can ‘send feedback’ through GFN, without any response, or contact live chat. Live chat leads to an Indian customer service that suggest using the ‘send feedback’ button in the end.

I’m aware CCP has no control over the service, but they do have stronger leverage in working out problems. Also, the problems happened ever since the new launcher / vanguard updates started, leading me to believe something isn’t going great in the implementation of Eve on GFN.

1 Like

I’m in the same boat as you Daliha, potato pc, use Geforces Now (Possible Never) Service to play games. Eve was working for me until about January but sometime glitching on downloading the updates. Now it’s unplayable shows as Offline for maintenance. Just goes to show that CCP apparently aren’t as good as they say they are and neither is Geforce. Got my money, that’s all they needed.

1 Like

I’ve played a lot of different games through GFN, and some of them get a better update timers than others. Rust for example has monthly (big) updates, but there are few times that takes more than an hour or so to update on GFN. CCP should really dive into fixing their service on GFN themselves.

Bump. The service has not worked for a moment after my last update. It’s been over 2 months now that people using GFN to play Eve Online could log in consistently.