Geforce Now is using the outdated launcher and Eve is now unplayable. Big oof! :(

Still no work :frowning:

https://www.nvidia.com/en-us/geforce/forums/gfn-general-chat/20/ I think you meant to post here.

1 Like

Thanks for the snarky / unhelpful comment, after raising a ticket with CCP the GM’s actually recommended me to make a ticket on the CSM forums. I’ve already tried contacting GFN with all their possible contact functions.

Service is still offline.

We are aware of the issue and are actively working with GeForce Now to get it resolved.

2 Likes

Thank you so much! Happy to hear work is being put into it. :slight_smile:

Seems like GeForce Now doesent appreciate the way CCP made their new launcher and CCP isnt going to change anything anytime soon.

I’ve been using Geforce Now for a long time, but I decided to play Eve Online only now (I’m a new player). I’m very surprised that this problem still exists. This is not typical for Geforce Now.
Now every day I check if the game is working

1 Like

Yeah, i’ve never éver seen a game unavailable for this long on GFN. I kinda threw in the towel at this point, thanks for forcing me to win Eve. :face_in_clouds:

I don’t want your stuff, you’ll need it when you lose again

…just put it in NPC station to not worry about assets safety hefty “tax” then, ok?

1 Like

Looks like it’s back since last Geforce Now update (few hours ago), only the native client tho.
I don’t play Eve but I opened it to see if was working on GFN.

So you dont play but you created a character to come here and post?