Launcher crashes on startup (0xc0000005)


(Olli Oppilas) #1

Since latest update the launcher seems to crash on startup without any logs. Crash is visible in Windows Event Log with code 0xc0000005 which I believe corresponds to an access violation.

I also opened a support ticket and will report here if I get any response to that.

edit: And I’m using Windows 10


(Selar Delazure) #2

I have the same problem on one of my machines (Windows 7) : it happens only since the last update. Reinstalling everything, including the whole PC did not fix it. No issue on my Windows 10 and my windows 8 rigs though.

[EDIT : this time I had a log]

|2018-08-28T14:22:32.671Z|default|debug|launcher.eveonline.com connected|
|2018-08-28T14:22:32.711Z|default|debug|resources.eveonline.com connected|
|2018-08-28T14:22:32.711Z|default|debug|binaries.eveonline.com connected|
|2018-08-28T14:22:32.711Z|default|debug|Checking version at "https://binaries.eveonline.com/evelauncher_win_release.json"|
|2018-08-28T14:22:32.713Z|default|debug|Scheduled task "Version info downloader"|
|2018-08-28T14:22:32.713Z|default|debug|Starting task "Version info downloader"|
|2018-08-28T14:22:32.713Z|default|debug|"Version info downloader" go: 0|
|2018-08-28T14:22:32.765Z|default|debug|Official version is "1371204"|
|2018-08-28T14:22:32.765Z|default|debug|onWineCheckFinished|
|2018-08-28T14:22:32.765Z|default|debug|refreshServers ""|
|2018-08-28T14:22:32.765Z|default|debug|Calling refresh on "tq"|
|2018-08-28T14:22:32.765Z|default|debug|Finished task "Version info downloader"|
|2018-08-28T14:22:32.766Z|default|debug|Scheduled task "Patch info downloader for Tranquility"|
|2018-08-28T14:22:32.766Z|default|debug|Starting task "Patch info downloader for Tranquility"|
|2018-08-28T14:22:32.766Z|default|debug|"Patch info downloader for Tranquility" go: 0|
|2018-08-28T14:22:32.777Z|default|debug|Finished task "Patch info downloader for Tranquility"|
|2018-08-28T14:22:32.777Z|default|debug|Build on "tq" : "1371762" - public|
|2018-08-28T14:22:32.777Z|default|debug|"tq" : Last build was ""|
|2018-08-28T14:22:32.777Z|default|debug|grpc Queueing eve_launcher.ClientUpdateStarted : start_time { seconds: 1535440952 }|
|2018-08-28T14:22:32.777Z|default|debug|Downloading public binary index for "tq"|
|2018-08-28T14:22:32.777Z|default|debug|Scheduled task "Index downloader for Tranquility"|
|2018-08-28T14:22:32.777Z|default|debug|Starting task "Index downloader for Tranquility"|
|2018-08-28T14:22:32.777Z|default|debug|"Index downloader for Tranquility" go: 0|
|2018-08-28T14:22:32.790Z|default|debug|Finished task "Index downloader for Tranquility"|
|2018-08-28T14:22:32.790Z|default|debug|Index size: 17173|
|2018-08-28T14:22:32.791Z|default|debug|Current build "1371762" different from last downloaded "" - downloading from binaries index|
|2018-08-28T14:22:32.791Z|default|debug|Scheduled task "Downloader for Tranquility"|
|2018-08-28T14:22:32.791Z|default|debug|Starting task "Downloader for Tranquility"|
|2018-08-28T14:22:32.791Z|default|debug|"Downloader for Tranquility" go: 0|
|2018-08-28T14:22:32.815Z|download|debug|"Downloader for Tranquility" addMissingFilesToQueue checking 125 files|
|2018-08-28T14:22:32.818Z|download|debug|Downloader for Tranquility addMissingFilesToQueue took 0.003 seconds|
|2018-08-28T14:22:32.818Z|default|debug|Downloading bundle for "eveonline_1371762.txt"|
|2018-08-28T14:22:32.831Z|download|debug|Resuming "Downloader for Tranquility"|
|2018-08-28T14:22:32.831Z|download|debug|"Downloader for Tranquility" has 7 files to download|
|2018-08-28T14:22:32.831Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.1 ( bundles/1371762/eveonline_1371762.txt.bundle.1 )|
|2018-08-28T14:22:32.833Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.2 ( bundles/1371762/eveonline_1371762.txt.bundle.2 )|
|2018-08-28T14:22:32.834Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.3 ( bundles/1371762/eveonline_1371762.txt.bundle.3 )|
|2018-08-28T14:22:32.835Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.4 ( bundles/1371762/eveonline_1371762.txt.bundle.4 )|
|2018-08-28T14:22:32.836Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.5 ( bundles/1371762/eveonline_1371762.txt.bundle.5 )|
|2018-08-28T14:22:32.837Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.6 ( bundles/1371762/eveonline_1371762.txt.bundle.6 )|
|2018-08-28T14:22:32.839Z|default|debug|Downloading bundles/1371762/eveonline_1371762.txt.bundle.7 ( bundles/1371762/eveonline_1371762.txt.bundle.7 )|

(Cika Brka) #3

Same here, reinstalled and updated everything… filing a support ticket next


(EA Leguard) #4

Please read this thread for fix! Evelauncher.exe - System Error


(Olli Oppilas) #5

That thread only has fix for a Windows 7/8. This problem happens for me on Windows 10.


(Brankos BasCelick) #6

That fix is nort working for me. BTW how do you fill a support ticket. My win is dead now.


(Olli Oppilas) #7

Only method so far that has worked for me is to download & install an old launcher and use that.


(Brankos BasCelick) #8

@Olli_Oppilas
Where can you download the old launcher?


(Olli Oppilas) #9

This should work (it will nag about updating, just cancel it). More recent one will work as well but thats the one I had in my download history.
http://binaries.eveonline.com/EveLauncher-1225328.exe


(Brankos BasCelick) #10

@Olli_Oppilas
I cant bealive but this was working for a 1min, launcher was up finally and start updateing, and then again stoped and that erroe 0xc000007b again. How to stop launcher to update to new version? But to update everything else?
btw do you know maybe number.exe of the more recent one?


(Olli Oppilas) #11

Sadly no, that worked for me. It did crash on first run for some reason but worked well after that.


(Brankos BasCelick) #12

Well i can istall the old one, cancel the update, bur after i choose a caracter and try to log on, first i get error that cant write on disk, something with shared cashe, after that crashes again with old error 0xc000007b, and after that want start at all


(Bill Standen) #13

Same problem here, tried multiple launcher versions and all failing the same way immediately after starting the EVE Launcher.

Faulting application name: evelauncher.exe, version: 5.0.138.309, time stamp: 0x5b916827 Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0x00000000 Faulting process id: 0x3d60 Faulting application start time: 0x01d44cc42c7534ea Faulting application path: C:\EVE\Launcher\evelauncher.exe Faulting module path: unknown Report Id: 65f5f102-66ee-4c48-adf8-9fd5b837e7b3 Faulting package full name: Faulting package-relative application ID:

No log, not even an attempt to draw the actual Launcher Window.

I’m on a fully up to date Windows 10.


(Olli Oppilas) #14

Yup, I have been chatting with support on the issue but sadly no progress yet…


(KIAHicks) #15

Same problem here. Windows 10 64bit.

Exception code: 0xc0000005
Fault offset: 0x00066798
Faulting process id: 0x1a78

Launcher crashes as soon as you start it, only shows up in EventLog. Filed a support ticket earlier today.

Downloading and using EveLauncher-1225328 from above link works, although if you let it update, it’ll crash again.


(GM Mechanic) #16

Same issue happens with the latest version?

https://binaries.eveonline.com/EveLauncher-1381807.exe


(Olli Oppilas) #17

Confirming the latest version fixed the issue for me. Thanks!


(Bill Standen) #18

Still broken for me. Same instant crash as above.