Launcher is not working

Hi, I start the Launcher, i put in my details it then goes back to showing me the username and password box again, there is no error just and endless loop of my typing username/password and back to clear boxs again, i tried logging to submit a support ticket i get this

i have tried it on many accounts and get the same issue.

I have verified the cache and moved it, still got the same

i now deleted the cache and still the same issue,

in the end i had to login to my accounts (one at a time), i would get the error above then go via the luancher to account managment and it would log me in i then change the password for every account and now it works. My old passwords where 13 characters long a mix of higher characters, numbers and caps/lower case. the new password is even longer and again a mix of everything and different on my accounts. this is clearly something server side. not client. i suggest if you get the same issue change your password first before going through a 10gig download.


Same problem here. All worked normally before patch of this day. After, i’m unable to log in with all account.

Network diagnostics trace route says “request timedout”.


I am an EU/UK player Also having SAME problem as the first poster.
Also When i try to log into Account management on the Website i get this error …
{“error”:“invalid_request”,“error_description”:“Some parameters are either missing or invalid”}

CCP Please Help us !!

same problem


Found a Resolution to this problem…
Change your passwords and you will be able to log in.
thats what i did

I am still having the same issue even after resetting password.


i would verify the cache and try moving it to rule out something odd, then relaunch eve and see if that works. i would hold off deleting the cache unless you got a very fast internet connection. but this does point to something CCP has done.

Already tried all the basic troubleshooting stuff. reset computer, try separate internet connection, different computer, verify cache, erase cache, reinstall launcher. This is a server side issue.

1 Like

yeah same problem here tried to verify that didnt work , restarted the pc , that didnt work re downloaded the game that hasnt worked either so ticket sent in

Change your password to something 12 characters long or more. that will fix the issue. CCP broke something on their server side with weak password warnings and broke people logging in.

This issue was related to dual auth for my acct. Would have never discovered it if I hadn’t used the “Customer Support” thing on the launcher. Was able to replicate the problem there when attempting to login to the cust supp website and received an error about cookies when submitting the token after that endless loop.

Since reset pwd did nothing next logical step was to remove the authenticator based on this error.

So confirmed this is an issue with the way accounts are being authenticated on the server end.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.