Launcher not allowing 'add account' steam/linux

HI all, have tried this a few times and re-installed the OS 3 times.

When you install Steam and then the eve launcher, i have tried to add my Omega account (which was working up until a day ago), each time i enter my name and password, the launcher then sends a verification code to your email, once you enter the verification code i get “incorrect verification code”, which has me stumped, but also get the message ‘cant connect to the internet and check your internet connection’.

Now i know my internet connection is NOT an issue, as i have been able to recieve updates for the launcher, and also install the full game client from the launcher (27gb), i can log in with the associated steamxxxxxxxxxxx account but that account wont be used, i am trying to add my omega and other alt account and it isnt allowing it?!

Has anyone else had this issue? know how to solve it? ive lodged a ticket but as CCP does NOT support linux (only windows and mac).

Operating System: Linuxmint 20.10 (ulyssa)
Proton: 5
Wine: 7.10 (allowing dx11)

any help to solve this would be greatly appreciated