Linux After DX9 Shutoff/ Any idea how to get DXVK running with linux launcher?

So, todays the day that CCP decided to force everyone to use DX11 - While the linux launcher supports it, transparent surfaces are not displayed at all(overview windows are half visible, ship controls only sho the ammo count and the rotation of an active module being on and so on) - me being playing on an intel igpu at the moment I first thought it was due to lack of support from the gpu part of the cpu. Turns out, graphics are fine when running via lutris+DXVK, however with me playing the game in a multi-monitor windowed environment, I get mouse issues(when I have it on the right-of-center display every left mouse button click spins the ship 360 degrees and windows when clicked will move to the far right of screen, so thats a bust. However this was fairly easy being fixed by moving EVE to the center display. Undesirable but ok. Now trying to resize the dscan window expands it to the middle of the screen wihtout any fixing options. I figure this is somehow an issue with lutris etc since I didnt and dont have those issues when using the linux launcher.
Now, question is, is there any way to add DXVK to the wine binaries shipped with the linux launcher? When I try installing those binaries into the wine environment shipped with the linux launcher, the game refuses to start claiming wine wasnt built with vulkan drivers - have not been able to fix this. did anyone here get this fixed? if so, how?

Linux launcher is the discontinued one from CCP?

The latest wine-staging should run the windows launcher just fine:

I managed to get it to run now, by installing eve via lutris, then moving over the DXVK stuff and the wine binary into ~/.eve into the appropriate subfolders. The linux launcher now launches eve clients with DX11 on vulkan via DXVK, however with DXVK I still get weird mouse issues:

  • If eve isnt on the primary screen, Left Mouse Button will do a view Rotate of 360 degrees but not do anything else except move any clicked window to the far right of screen
  • If eve is on the primary screen, controls seem somewhat ok, however right mouse button only works on windows, like station interface, inventory window etc but does not work in space(which makes navigating in w-space harder than neccessary.
  • if eve is on the primary screen, trying to resize the DSCan window will always expand it to about 2/3 width of the screen, the only way to resize it is to move it to the right corner of the screen and then resizing it down to the right from the left side.

These issues also persist in lutris

Anyone know a fix to that?

I’m also having some trouble on Linux. I use Wine. The launcher is running fine. Within the game though, while docked, all windows are ultra transparent so that all that I get is a mess of writing on the screen, almost impossible to tell from which window any given bit of writing is originating. Also, the icons for inventory, etc. are missing. Haven’t tried to fly anywhere, I’m pretty sure that would be a disaster, given I even have trouble seeing an “undock” button! Unfortunately, I’m not familiar with Lutris, I’d have to do some research to figure out what is needed there. Anyway, I’m chiming in here to let people know that your not alone, after the DX9 shutoff I’m not able to do much of anything, things were fine prior to that! Time to figure out what’s going on. I’m not new to Linux, but I’m fairly new to gaming on Linux, so it might be a bit fun sorting things out…

I had the same issue. Its something specific with Lutris. I tried disabling all the features and using an alternative wine version but still had the same issue. I ended up just running it with wine via CLI using the prefix Lutris created (dxvk overrides intact).
No longer have that issue.

Edit for verbosity: I tried GNOME3 under both Wayland and X11 to ensure it wasnt my window manager causing any issues but the problem remained.

Awesome! This worked for me too. I also tried different window managers to make sure that wasn’t it. Wasn’t really clear to me what I needed to do to make it work without Lutris so for future reference:

The following command will create a startup script to run EVE without starting Lutris:
lutris eve-online -b

Edit the file and replace the (in my case) ~/.local/share/lutris/runners/wine/lutris-fshack-6.21-6-x86_64/bin/wine with just the simple /usr/bin/wine.

You’re custom run script is now ready. This works for me. I don’t have the 360 - 1080 spin on my second screen.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.