New launcher... new Linux error?

It dawned on me… that setup_dxvk was something needed to install lol, so I did a search and there’s a file to download. I suppose I didnt see a reference to downloading this file prior to try it :wink:

Im confused, I read that I would need to copy/overwrite the included 64bit dll’s… the only place I found similar named files are on the .eve/wine/lib/wine/fakedlls , do I have to put them here?

I think I’ll hold on this untill given more ideas/help :slight_smile:

From what I’ve been able to gather, I can download setup_dxvk from the GITHUB and all I got from there is a setup_dxvk.sh with 2 folder with DLL’s for 32 and 64bit, as far as I can tell this wouldnt work with the command shared.

Then, decided to make a search for setup_dxvk and it seems theres another file I was able to download, but all it was its a script it seems, named dxvk_setup.1 and I did try to modify the given command from earlier and rename the file so that it fits with this and it gave me an error command not found.

You don’t need to mess with the DLLs manually at all–setup_dxvk does it for you. Make sure you’re using the precompiled download here: https://github.com/doitsujin/dxvk/releases/download/v1.9.2/dxvk-1.9.2.tar.gz

From the dxvk-1.9.2 folder, run WINEARCH=win64 WINEPREFIX=/path/to/eve/prefix ./setup_dxvk install --without-dxgi

That will symlink the DLLs in your EVE prefix and set the overrides for you.

Still confused with the path to eve lol

The command as you put it, but with /home/user/.eve as path to prefix gave me “no such file or directory”, Had to add .sh so that it said other things, first /home/user/.eve not a valid wine prefix, then I tried with /home/user/.eve/wine but keeps saying not a valid wine prefix.

So, what is then a valid wine prefix?

Adara, launch your file exporer and navigate to your home directory. View hidden items by using the shortcut ctrl+h. You should see a directory in there called “.eve”.

So here the path to your Eve files within the .eve directory would be your prefix. Typically, the full path in this instance would be something like “/home/.eve/wineenv/drive_c/tq”

Another location for you might be in the Steam directory for Eve, e.g.: “/home/.steam/steam/steamapps/common/Eve Online”

Explorer around your system. You might have multiple installations/locations.

The prefix just points to the root of the virtual windows drive, not the actual eve installation. So in that example the prefix would probably be /home/user/.eve/wineenv

If it complains that it’s not a valid prefix then whatever tool you used to install it is doing weird/custom stuff with the setup and I can’t really help you. Using convenience tools and wrappers around wine programs makes it hard to diagnose problems because they add layers of complexity to something that get in the way of troubleshooting. Most of the people in these threads that are having trouble with the patches/workarounds are people using the deprecated native launcher or lutris it seems like.

Just for reference, here is all that is required to get the game to run on a direct wine setup:

  1. Download the windows launcher
  2. Install the latest wine-staging (6.19)
  3. Create a new wine prefix with the desired install (prefix) location
WINEARCH=win64 WINEPREFIX=/home/user/eveprefix winecfg
  1. Set version to Windows 10 in the dialog that pops up, navigate to staging tab and disable CSMT. Close Dialog
  2. Download latest dxvk from https://github.com/doitsujin/dxvk/releases/download/v1.9.2/dxvk-1.9.2.tar.gz and extract it
  3. Install dxvk in the prefix
WINEARCH=win64 WINEPREFIX=/home/user/eveprefix ./setup_dxvk install --without-dxgi
  1. Run the installer with wine in your prefix
WINEARCH=win64 WINEPREFIX=/home/user/eveprefix wine EVE-Installer.exe
  1. Play the game with the workarounds described in this and other threads until the patch that fixes the bug is merged upstream. Depending on your distro, Wine will probably create a desktop launcher for you with all the parameters set that you need to play, so launching it will be more convenient going forward.

If you notice the pattern above, WINEPREFIX before wine commands just tells wine which virtual Windows system you want to use when doing things. If that folder doesn’t exist it will be created the first time. It’s considered best practice to keep separate prefixes for different programs so that hacks to fix one program don’t affect others. I keep all my prefixes under a common directory like /home/renard/prefixes.

2 Likes

Thanks for the step by step, I’ll try to make a new one then. I didnt use any other helping tools, just what you described, but the concept of prefixes is still something that it will take time for me to get. I only play EVE, and I dont have time for other games really, so I probably dont need a folder to save them all. I was trying to add dxvk to my existing .eve but this one is using the deprecated Linux Launcher, which is still working, surprisingly, but with a lot of CPU overhead.

I wonder if I can download the most recent windows launcher to set it up…

And yes, you are right, I have a bunch of EVE installs, trying different things hoping one would work. With Lutris I had 2, then I had Steam, and the Linux Launcher.

@Obrym: Thanks, but I dont think you noticed that I already was seeing .eve :slight_smile: However you did point out that my path was incorrect.

I’ll follow Renard’s guide and make a new one.

PS: Ok, followed the instructions to the letter, in all forgot to rename user to my user haha. Its currently installing. I’ll copy the launchdarkly.pyd once its done. Ah, also the eve profiles for my clients. Thanks Renard

Good luck! Also note that installing EVE this way doesn’t mean you can’t continue to use Lutris/steam/etc for other games. It’s helpful to know how to do this manually in cases where things don’t run with Lutris and require manual troubleshooting steps with normal wine.

Remind me where do I need to put the profiles :slight_smile: for the overview and window setup I already have?

Noted, thanks. Lutris has worked great for so much time, hopefully everything goes well and works like it was in Lutris.

Try launching the game and making sure it runs before migrating your profiles IMO. I’ve never actually moved profiles before but any Windows guide should do, just look in PREFIX/drive_c/EVE/SharedCache for where to put them

Client is working :wink: So far on idle, docked, getting 35-53% cpu usage (with 5 clients), which is great :slight_smile:

Profiles had to be copied to:

eveprefix/drive_c/users/username/AppData/Local/CCP/EVE/c_eve_sharedcache_tq_tranquility

:wink:

PS: Added the note on how many clients :slight_smile:

Is there some way to configure the launcher to prevent it from updating? I’ve been clicking cancel, but the dialogue glitched out today and the update was unavoidable.

On the other hand, is there some way to roll back to a previous launcher?

I strongly recommend against trying to stick with an old version of the launcher. It’s only a matter of time before it stops working for good

So if I follow these instructions, I can use the up-to-date launcher? I thought that was part of the “workaround”

Also, I get wine-staging 6.18 from my package manager. Is that good enough or do I really need 6.19?

The workaround is to move a file one directory up in the latest Windows launcher, or to apply a patch to wine or wine-staging that fixes the root cause. Using an outdated launcher is an older “workaround” for a previous problem that was already fixed in wine

6.18 works fine too, anything above 6.14 I believe

1 Like

I’ve followed your steps exactly. I move the file launchdarkly_client.pyd up a directory. then I run
WINEARCH=win64 WINEPREFIX=/path/to/prefix wine eve.exe

The launcher starts and communicates with the eve servers. I am logged in. When the play button is available I click it. I get the little pop up telling me that the client is launching. After 10 minutes, nothing has happened. std err is uploaded at the link below.

Sounds like you didn’t set launchdarkly to read only after moving it. In the launcher options toggle the option to launch with loglite and see what a errors you get.

You have to either set it to read only or move it AFTER starting the launcher because the launcher actually deletes it when it starts

Wish we could put those instructions pinned at the top :slight_smile: it would save a lot of time for many to find the way to use it. Oh, and I’m running Wine Staging 6.19.

1 Like