Low quality/blurry textures on some things on max quality settings

Hello everyone,

I experiencing some low quality textures on ORE exhumers and Buildings, I wish to know if exist any solution about this.

I have a 3080 and my Operative System is Windows 10, my resoultion is set to 3840x2160.

I have tried to:
-Switch between Directx 11 and 12
-Turn off AMD FSR
-Forcing the anisotropic filtering to 16x (with “High Quality” in additon) on Nvidia Control Panel.



This looks off indeed.

Have you checked your texture quality settings? (Maybe changing it around helps)

Is the checkbox to load the full client is checked in the launcher?
grafik

Under Tools / Cache in the launcher, you can also try to verify game files.

(I’m just guessing around.)

If that’s not it, I’d send a ticket with your screenshots attached.

I checked the textures, switching to “medium” and then back to “high”: got the same blurry textures

The “Full client” is checked.

I also switched to “DirectX 11” to see if it solve the issue, but still got the same blurry textures.

I tryed to verify the game files, but the issue remains.

Nora can you tell me please how to send a ticket to the support?

I still need to know how to send a ticket/report to the support, can someone explain to me how to do that please?