MAC Crashing

So, still the same issue as has been reported previously, the game crashes, particularly bad around Jita / Other trade hubs and usually has a limit on the number of jump gates you can go through – usually 5-6 (this varies depending on your graphics settings).

So while the work around is to just cut your graphics down, I feel like I’ve cut my game back to 2003 when Eve launched (Honestly, I think it looked better in 2003, then it does now).

Are there any other suggestions out there or does CCP have some insight they can share on when these memory leaks might get fixed?

If you need logs or other information, happy to provide everything and anything you need.

Items I’ve tried:

  • Cleared the Cache
  • Download everything : Checked, unchecked
  • Logging: off
  • DX9 : checked and unchecked
  • Enable high DPI Scaling: Checked (Crashes faster) ; unchecked – no difference
  • Enable Hardware rending: both checked and unchecked
  • Dev Branch: always CCP-Master
  • Wine Version: Latest -> 2.22-114 -> 2.6-195 -> (after this version the client becomes too unstable)
  • WineDebug: Always cleared
  • Retina Mode: Always unchecked
  • Video Memory: I’ve done default, 2048, 3184 and 4096

In game settings:

  • Windowed Mode
  • Window Size: 1920x1080 -> 3840x2160 and various values in between
  • External and Internal Monitor
  • I clicked on “Optimize for Performance” which dropped my settings from all High to:
    – AA: Disabled
    – Post: None
    – Shader : Low
    – Texture: Medium
    – LOD: Low
    – Shadow : Disabled
    – Low Quality Characters: checked
    – Texture Quality: Medium

Effects: all Checked

Macbook Pro (15 inch, 2017)
CPU: 2.9Ghz
Memory: 16GB
Graphics: Radeon Pro 560, 4096MB

High sierra: 10.13.5

1 Like

I’ve literally tried everything, but it’s a cumulative effect based on the number of jumps. Minimizing your graphics settings only buys you a few minutes to delay the inevitable lockup.

Long story short, no one buys a Mac for gaming, especially a laptop. Mac has their niche, and gaming is not it.

Uninstall EVE and install Photoshop, After Effects, and Final Cut Pro and everything will be right as rain…

1 Like

Arthur: Basically, yes. When I cut the graphics down, I got 30 or 40 jumps instead of 5 or 6. Seems to have been a long standing issue around here.

I’ve been running on a MacBook Pro 2016, high settings for a few weeks now, been to Jita and back, total of 40+ jumps. I have not experienced crashes due to jumps. I have had a single lockup event, but don’t recall it being related to anything. I installed EVE client through Steam, not sure how or why that would make any difference though, if others haven’t installed using Steam.

Had a limited amount of time for testing. Did about 7 jumps out and back in a Claw, went through a trade hub as well. Graphics setting were high, and running same machine as OP, just one year older. Saw memory usage for wine peak as high as 2gb, and went as low as 1.4gb, usually averaging around 1.7-1.8gb. Memory was deallocating fine after each jump, and never really saw any pattern of a memory leak.

If running the same OS, every machine should be the exact same, except for some moderate variation in hardware which shouldn’t really matter, therefore they should all be experiencing the same problem. And my machine is very close to OP’s. I run my Mac very plain, I don’t do a whole lot of settings fiddling or customization. I have read other posters saying they have similar problems, but it’s a mystery why some machines are fine and others are not. It’s not much help, but the answer likely lies in the differences between the two, whether it’s settings, Steam, or possibly corruption somewhere, or heat?

1 Like

Did you happen to note if you were getting into the swap memory?

I also use multiple Macs and do not experience these crashes when playing. Oddly, the one thing I could do to get my oldest machine to crash regularly on was typing in chat too quickly-LOL. But, that’s a dog of a machine and not worth talking about…

I’ve played on underpowered MBAs with 8 GB of RAM and even there, no crashes or obvious memory leak.

Not saying that I don’t believe the posters, I absolutely do, but just adding a data point that I do not experience these kinds of crashes either using essentially “stock” settings for the EVE client and WINE.

1 Like

MC / Leah, would you mind sharing your Wine settings and your in game graphics settings? I’d like to try and mimic.

I should note that I’m also running a 4K monitor – but I have experienced the crashes without any external monitor. Default Resolution for my MBP: 2880x1800.

I’m willing to try any settings you all can throw out there. I think I might uninstall and reinstall Eve altogether and see where that gets me.

As for heat, highly unlikely as the system doesn’t seize up – just Eve. Also, I run a sizable floor fan blowing right at my MBP as I don’t like the keyboard to get warm (which it will) unless I have the fan on. With this much air flow going over (and under as the unit is elevated off the desk by 2") the internal fan doesn’t even kick on.

Absolutely! Here is how my laptop is configured, running with the internal screen. i do have a Thunderbolt monitor as well, and the resolution is much different there, but the same settings and no crashes using that either.



Hope that helps. If there is anything you’d like me to try on my end to see if I can recreate the crashes, let me know and I’ll give it a go :slight_smile:


OP’s and my MBP both have 16gb memory, and at most I maybe achieved 5-6g total, so no swapping. If I watch Hulu, it might add another 1gb. I don’t think I can utilize max memory with my usage lol, but I’m sure others can. So this is something that may be taken into consideration.

I stayed with “default” preferences and settings. My wine preferences are identical to Leah, which is the one recommended by devs. However, in the top preference portion, my ‘download everything’ is unchecked, and ‘use system configuration for proxy’ is checked. Not sure why. Launcher settings everything is unchecked, except singularity and duality.

I use a regular HD monitor as external most times, so running at 1920x1080, and anti-aliasing set to medium, everything else is high.

Very cool, thanks for the info.

I’m curious to see if we can nail down the this memory leak people are seeing and what impact that might be having with the system RAM. That’s one of the reasons I’m curious about the swap memory.

If I get some time today, I’ll try to make some runs and keep an eye on iStat as I do it to watch for RAM utilization.

1 Like

I’m having the same issue. Running a mid 2017 27" iMac. 3.8 GHz InteL Core i5, 8GB ram with Radeon Pro 580 8192 MB graphics. I get about 20 jumps before the client locks up and it always happens when beginning a warp.

I am going to upgrade to 16GB of ram and see if that makes a difference although Wine only seems to be using about 2GB of memory so I’m not sure if will help much.

Not to disappoint you, but it’s probably not going to help.

Get a PC.

1 Like

Please keep us updated. I have the same exact setup as you, and have frequent freezes.
Funny enough, my 2007 iMac with half the RAM has never frozen up on me in game.

same here, my mac rig is well up to date and still have to restart cliente every hour or so

I notice you had the ‘Download Everything’ button ticked for your Settings. I do not have this section ticked and the game runs fine. I do not know what having that button ticked will do but I imagine the whole game gets downloaded?

That is correct

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.