Mac OS High Sierra


(Dallas Ovaert) #1

So with the latest release, I’ve started getting crashes every 5-6 jumps like the rest of the community. My Mac is pretty new, and while it’s not the end of the world as it’s home to an alt-char I’d like to have it working correctly.

I have never updated the Wine backend, and would like to confirm …is something that we are supposed to be doing? My understanding is that EVE is packaged with Wine internally and is now updated along with the game…correct?


(Leah Crowleymass) #2

Sorry you’re having issues.

At this point, I am really wondering what magical thing I did, since I do not have this issue on any of the Macs that I use- and I regularly make very long trips.

If it helps, here is a post where I list all of my settings:

I’d be interested to know if you have anything set differently, and if changing anything helps.


(Dallas Ovaert) #3

It’s just very odd that I’ve had no issues for the past 2 years, and then all of a sudden…it’s starting to crash. I’ve got some things to check, and my settings are pretty close to yours although not exact…so I’ll try matching them up and see what happens.


(Graham March) #4

in the support/bugreport i got an answer:

CCP Dev
Hello,
Thank you for contacting us regarding EVE on Mac issues.
EVE client performance and stability under Wine can improve with some alterations to the default settings:

Windowed or Fullscreen: Window mode
Window size: 1920x1080 (or lower)
Shader Quality: Medium

If you find your performance degrades over longer gameplay sessions it is advised that you find a safe spot to logout and restart the client.
Be sure you have selected the following settings in the Launcher preferences:

  1. On the Launcher go to EVE Launcher -> Preferences…
  2. Make sure “Version type” is set to Release
  3. Check “Download everything” (recommended)
  4. The following seven options should all be unchecked
  5. “Thread count for resource download in client” should be set to default
  6. Under Wine options:
  • “Use dev versions” should be unchecked
  • Dev branch should be ccp-master
  • “Wine version” should be Latest
  • WINEDEBUG should be blank
  • Uncheck Retina mode
  • Set Video memory to “Auto detect”

If you’re still unable to run the game with these changes, I would suggest verifying your game installation:

  1. close the game client
  2. on the launcher go to View -> Shared Cache…
  3. click Verify
  4. wait for the process to complete
  5. restart the launcher

So the game seems to be MUCH more stable with 1920x1080 fullscreen and medium shader setting. (other optimized to memory economy)

But im dissapointed playing on 5k (Carl !) iMac with such resolution and low grafics as if i played on a calculator.


(Graham March) #5

in bootcamp windows 10 i can play on this iMac stable with ALL MAX graphics with brilliant fps.
That is pain!


(system) #6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.