macOS Client Freezing - womp womp

I encountered the wine64/macOS client freezing problem after upgrading to a new machine. I tried a lot of the forum recommendations and none of them worked for me.

My previous post regarding using the (1x) settings in EasyRes was not a help. I’ve gone over lots of different

After one successful night, it was followed by the opposite tonight. EasyRes is still a great application but for whatever reason I had luck last night, it was not actually a help.

Update: womp womp

Well, if you’ve tried all the suggestions and generic troubleshooting steps, you might want to run some hardware tests. I know it’s a new computer, but sporadic problems can be indicative of hardware that is begining to fail, and even brand new parts can sometimes go bad. I don’t know what testing tools are available for macs, but you can use the free version of memtest 86 to test your RAM (it requires you to make a bootable USB stick). Check your hard drive manufacturer for a hard drive test.

If you have a multimeter, you can look up tutorials for how to test your PSU, or you can buy an automatic tester for like 12 bucks or something.

Anyway, file a support ticket if you haven’t done so already, and please come back and tell us how you fixed it. Might help the next guy with the same problem.

Alright so after plodding through this trying some more recommendations I found, I’ve gone two sessions without a freeze. I don’t know the specific combination that helped, but here is where I’ve landed.

EasyRes = resolution set to a 1x variant
EvE Preferences =

  • version type: beta
  • download everything: checked
  • use system config for proxy: checked
  • enable hardware rendering: checked
  • use dev versions: checked
  • dev branch: winehq-binary
  • wine version: latest
  • Video memory: auto-detect

if not listed as checked, option is unchecked

Client’s video settings:

Window mode, 2400x1238 window size
UI Scaling 100%
Present Interval - Interval One

All Camera Settings: unchecked

Effects:

  • turrets + launchers: checked
  • effects: checked
  • missle effects: checked
  • explosions: checked
  • trails: checked
  • asteroid environments: checked

Graphics Content Settings:

  • resource cache enabled: unchecked
  • anti-aliasing: low
  • post processing: none
  • shader: medium
  • texture: medium
  • LOD quality: low
  • shadow quality: disabled

I’ve gone two sessions like this so far over the past 24 hours without any session freezing what-so-ever.

Previously I tried almost the same settings except I used Wine 4.13 v206 per a previous thread that recommended it. I may have gone through a few other versions but quite possibly the “latest” dev Wine version helped.

I’ll post more to this thread if I have additional details but the above has given me over a day of smooth, uninterrupted, non-buggy play which is an improvement of note.

1 Like

Final update: I’ve gone several days without a single issue with the above settings. Ultimately going to assume that native client is going to phase out this issue, but hopeful my settings report is useful to anyone else having this problem in the meantime.

Thanks!