UPDATE: Client Freeze Issues – MacOS 64-Bit Client

We’re happy to announce that we’ve resolved most of the known issues with the 64-bit Mac client for EVE Online, however, there is one remaining client freeze defect specific to the 64-bit client that we’re still investigating and trying to pin down a root cause for.

This issue only occurs on the 64-bit version of the Mac client, which means that it will potentially affect all EVE clients that run on Apple’s newest OS (10.15 Catalina) when it releases, as this OS will be 64-bit only.

All previous versions of Mac OS still support the 32-bit version of the Mac client, so the current workaround is for pilots playing on Mac who are experiencing the problem to switch back to the 32-bit version of EVE Online for now.

All pilots should be aware that if they upgrade to Catalina (10.15), they will only be able to run the 64-bit version of the EVE Online client, which will prevent them from reverting to the 32-bit version if they experience this issue.

We’re working as swiftly as we can to resolve this issue with the client, but with the impending release of Catalina, we wanted to ensure that our Mac community is aware of this issue, especially pilots who have experienced this issue and have had to revert to the 32-bit client while we fix it.

If you experience this issue while playing on Mac, please report it via the EVE Online Bug Reporting Website and switch back to the 32-bit client via the EVE Launcher.

We’re working closely with our partners at Codeweavers to resolve the issue and we’ll be sure to release more information as soon as it’s available.

Apologies for any disruption this issue is causing our Mac community.

6 Likes

Nice one. Thanks for the heads up.

Though I didn’t update to Catalina yet, I fiddled around with the 64 bit client, as I encountered tons of trouble with it. Although, I got to get it running for now:

  • Select “Use Dev Versions” for Wine, then select a 4.4.* Version
  • Enable 64-Bit Client, AND check the “Use DirectX 9” box
  • If you still run into a “black screen” in game, disable Post Processing in the graphics settings

That does it for me, and that should also work in Catalina. I’ll see how stable this will run with the older wine version.

Up dated my MacOS to Catalina: now no more EvE, Launcher just freezes

I flipped back to 64Bit version yesterday after seeing this post @CCP_Falcon. Reverted the graphic settings too ‘high’ after needing to go to potato mode when using the 32bit version.

I managed to play to for about 5 hours, running two clients, without any crashes or black screens.

I am running iMac (2017) with 10.14.6 (18G95) macOS Mojave.

I upgraded to Catalina, switched to the 64bit client and it worked pretty well. Small issues though, like my scanner probe window has no lines for the orbiting things, and I can’t see the scan probes. Also, the map has no lines between the systems showing connections.

1 Like

I updated to Catalina- still getting the 64-bit error and the game doesn’t launch in 32-bit. It says it adds my account to the queue and then nothing happens.

I’ve been using the 64-bit client on Mojave. It wouldn’t work at all before the last Wine update, but it’s been great since then. Very smooth and performant. I think I’ll hold off updating to Catalina for a while, though, just in case.

As pointed out in the original post, Catalina is 64-bit only. You can’t run a 32-bit client on it.

I updated to Catalina before seeing this post so it was more as a heads up for other people that this is the case.

Could you please link the post? You’ve linked Falcon’s profile.

I have not been able to run Eve on
my Mac pro (Mojave), iMac 2012 (Sierra) or 2019 iMac (Catalina) since the September update. I’ve tried the lot; absolutely nothing works

  1. Reverting to 32 bit - Launcher crashes (Mojave & Sierra)
  2. Running eve via parallels 15 (Huge GPU temp increase, massive graphics glitches)
  3. When I managed (briefly) to get eve working on Catalina; the probe scanner window didn’t show the probes or the system (ie useless to find sites etc)
  4. Other things which happened with Catalina - Cannot use antialiasing (instant crash & need to restart the Mac); same if you they to use the post processing option, & just a normal crash if you put the shader on more than Low.
  5. Because of this, I switched to 32 bit (which was my fault), but switching back to 64 bit has just left the launcher hanging.

I’ve tried all the wine options etc. nothing works

All in all a pretty poor show; 3 different Macs, running 3 different OS, all crashing ?? -

Sort it out please !

Upgraded to Catalina and 64bit is hanging - any news on the progress of this issue?

I have EVE running on two computers w/MacOS Catalina but it is limping graphics wise as the shader and textures are set down to medium. So far no crashes. But I still have the sub-windows black. Here is a video of all my settings…

Thanks that work around helped me to get login and get ship back to safe port. Hope CCP can come up with a stable update, seems like every update this sort of round of glitches occurs.

This was a solution I received yesterday:

This latest update will ensure compatibility with the 64 bit version of the client, resolve any issues with the client not starting properly or repeatedly crashing.

For this change you will need to change your wine to the latest version. To do this please do the following:

  • Start the launcher.
  • Click on EVE launcher in the apple menu at the top left corner of the screen.
  • Select preferences.
  • Enable ‘Run clients with 64 bit’.
  • Make sure that ‘Use Dev version’ is not enabled.
  • Make sure wine version is set to latest. If it is already on latest switch to wine-4.17-Staging-winehq-binary-208, close the preference window and open again and switch back to latest. This is to fix those launchers that may be stuck on old wine versions that are no longer available.
  • Click Ok.
  • Close the launcher and the client if either is running.
  • In finder, click Go to Folder and copy paste the following: “~/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache”

You should see a folder named wine – move that folder to trash. Restart your launcher and wait for a few minutes for the launcher to update before starting the game again.

Maybe it can help others.

Nope. Tried this as written.
Client still will not launch.

The latest patch has not fixed this. If I tab to a different application, for example a browser, Eve instantly freezes and requires a ‘force quit’ to get it going again. Makes no difference whether I use latest wine or .208 wine.

Likewise - I can’t get any combination of WINE or 32/64 or DXx to actually launch on Sierra. The 64 bit client was working fine for me from beta up until about 2 weeks ago, and since then I’ve barely been able to log in - the 32 bit work-around worked for a bit, and now nothing does.

I upgraded to Catalina and tried Xazinstra fix but the launcher still freezes in 64bit.

Update: I got it running by downloading https://www.eveonline.com/download and re-installing (replace current eve launcher app) 64 bit and using latest wine.