Feedback on 64-bit Mac Client

Hello Capsuleers!

Now that there has been ample time for you to get a feel for everything that is 64-bit, we would love to hear your provided feedback on your time spent with the client, as well as bring up any potential issues you may be seeing. Some items there might be particular interest in can include:

  • Memory usage
  • Performance metrics
  • Potential bugs that could be specific to 64-bit
  • But also your general experience! :slight_smile:

Feel free to leave a comment providing feedback on the 64-bit Client below, and fly safe o7

1 Like

I experienced crashes usually around session changes (docking, undocking, system to system, etc) but figured the logs were already sent and didn’t bother with any defect report. Both on my iMac and wifes laptop. Now I’m using bootcamp with win 10 on the iMac. Can run it with graphics set to higher settings, easier to set for triple monitors and the mouse isn’t jacked up. Jacked up meaning, i have a 4k retina iMac, so the game displays the mouse super small even though i’ve set the resolution to something like 1900x1200.

The crashes on the laptop haven’t happened today and I’ve been on for a few hours so, not sure if it was already addressed or just something that works itself out.

Really like the move. FPS has been good and seems to be more stable than before. Have seen reports of memory leaks but havn’t personally experienced any.

Had a bug today where all of my UI was reset. Don’t know if its related to the 64bit client, but it is also the only thing that is different from the years of it working.

All in all, good experience.

Maybe someone can help me to get my Mac mini to update to the beta.

From what I can tell and understand from the other forum topics

1: launch the launcher
2: click eve-launcher on the menu bar > click preferences
3: change version to beta
4: tic the little box that says run in 64 bit.
5: hit the okay button.
6: if nothing happens quit and relaunch the launcher.
7: pray that something happens
8: after some downloading blah blah. Launch a client.
9: check activity monitor > and it still says that the client is 32 bit😭

1 Like

Every time, I have found, that you begin the EVE Launcher, you need to recheck, via Preferences, to see if the 64-bit box is checked.

1 Like

I met the same issue

Hi! I don’t have 64-bit checkbox in launcher preferences. How can I fix it?
55

While this will not be 100% helpful I would like to provide the following:
Since June 11th, the client has crashed and frozen the computer four times.

  1. In game - full screen - best performance - while scanning in hi-sec for wormholes
  2. In game - full screen - best performance - in station
  3. In game - windowed - best performance - in station
  4. Out of game - in launcher - shortly after clicking to start the client.

MacOS Mojave 10.14.5 - 16GB Ram 1867 MHz, i7 3.1 GHz, Intel Iris 6100 1536 MB Ram

MacBook Pro 20\7 running MacOS 10.15 beta. I notice that there are 2 ways to set the EVE preferences:

  1. via the EVE Launcher > Preferences in the MacOS menu bar (also available via Command+comma).
  2. via the cog wheel at the bottom left of the EVE Launcher itself.

I note that using option 1 is not persistent: if I select “Run clients with 64 bit” then OK, a restart of the EVE Launcher sees the option deselected.

On the other hand, if I select “Run clients with 64 bit” via the in-launcher cog wheel menu the option selected is persistent.

However, regardless of how I make the 64 bit selection, the game does not launch at all. Launcher version is 1514997 Qt 5.11.1.

I too have switched to 10.15 (Catalina) and can confirm that the client does not launch. I have sent logs to CCP and they responded that Catalina will be supported when that version is officially launched. Most Apple followers think that will be mid-September. Now that the public beta is available and Apple is encouraging the general public to try it out, more and more CCP customers will be (temporarily) locked out.

I have attempted to run my clients in 64 bit mode.

Change stuff to beta, tic the run in 64 bit. Let the launcher do it’s “hip hip hurray”. Launch client, check activity monitor- “wine preloader” 32-bit using like 150% cpu (wine preloader = eveclient)

The wine preloader 64-bit is running as well, but at like 0.0000005% cpu.

Any tips?

I think its a bit much to expect CCP to support a buggy OS beta release. Catalina broke quite a few apps of mine, so I decided to swallow a sensible pill and restore a 10.14/Mojave backup. Good old Time Machine. :grinning:

I am running the 64-bit EVE client under MacOS 10.14.latest (Mojave). It took a bit of fiddling to get it running. Here:

  1. I am still unclear as to which option for selecting EVE Launcher preferences I should use (see my previous post), so I set BOTH to run the 64-bit client. I also enabled hardware rendering on both. In the MacOS menu bar preferences for EVE Client I left the “Version Type” option set to “Release”.
  2. in the EVE Launcher started my Omega main. The launch flag came and went as usual, then nothing.
  3. Too late to catch what happened, sorry, I started the MacOS Activity Monitor, highlighted the CPU button, and entered “wine” into the search field. This will detect any process with “wine” in its name. No processes containing “wine” were running by the time I started Activity Monitor.
  4. I quit and restarted the EVE Launcher, this time a new version of Wine began to download. Hooray, progress!!
  5. When the download finished, and having re-checked BOTH sets of options to ensure that the 64-bit client was selected, I tried to launch my Omega main again.
  6. My client launched without a hitch, and the Activity Monitor shows both “wine64-preloader” processes and a single “wine” process.

So, it looks like the 64-bit client is running. In game, I see that I am running version 17.06.1528739. Also, I can no longer copy and paste using the Command key which, if you’ve been reading the support articles, is something that happens in the 64-bit client. :+1:

ok, it’s running in 64bit, but still directX 9 – why?
i don’t see any improvment!

Hi there,
The client is broken on 10.15 Catalina dev data 3 with default launcher settings other than 64 bit client.
0009:err:d3d:wined3d_set_adapter_display_mode Failed to read mode from registry.
0009:err:d3d:wined3d_swapchain_activate Failed to set display mode.

i’ll try some different stuff like DX9 or dev versions of wine.

lol
dev branch WineHQ whines about a missing font and gives a website to get the font and nah
dx9 next

and after having to force quit the wine64-preloader up popped the client going nowhere with the same info level log entries as before.
DX9 also fails in the same way.

let me know if you want the logs from loglite sent somewhere or if you want me to post them

I have been playing a little more of late:
After the initial hiccups with the 64 bit client not wanting to stay checked, the client now launches in 64 bit. I am still a little weirded out by the 6-8 64 bit preloader that show up in the activity monitor though!!!

Is there an eta on DX9 getting killed off?

64 bit client
iMac 27’’ late 2013
3.4 GHz i5
32 GB 1600 MHz DDR3
GTX 775M 2GB

switched to beta, latest and 64bit - nothing happened (even nothing in log)
switched to beta, wine 2.22 and 64 bit - nothing happened (even nothing in log)
switched to beta, wine 2.22 and 32 bit - everything fine
switched to beta, latest and 32 bit - nothing happened (even nothing in log)
switched to beta, dev version, latest and 32 bit - nothing happened (even nothing in log)
switched to beta, dev version, tatest and 64 bit - nothing happened (even nothing in log)
switched to beta, dev version , 4.4 (196+197), 32 bit and 64 bit -nothing happened (even nothing in log)

All tests with launcher restart etc…

So, no 64 bit client running here - and logger without function if you did not start it manually before everything else :-/
Where can I sent the log file?

Imac (Retina 5K, 27-inch, 2016)
4 GHz Intel Core i7
32 GB 1867 MHz DDR3
AMD Radeon R9 M395X 4 GB

macOS Mojave version 10.14.5

EvE Launcher - version 1533874

checked run game client as a 64 bit application
checked enable hardware rendering
checked enable high DPI scaling

click launch
added 1 account to the start up queue

and then nothing happens at all.