Run clients with 64 bit option is not persistent (launcher)

Not sure if it’s mac only, but it’s super annoying. Have to set 64bit checkbox every time I start launcher.

This is only a Mac issue, I’ve created a defect for this and notified development.

So we have a beta version up now which should resolve this issue and the use 64 bit clients option should now persists between launcher startups. To switch to beta and help us test this:

Start launcher
In the apple menu at to top of the screen click EVE launcher.
Click Preferences…
Change version type to Beta
Tick Run client with 64 bit.
Click Ok.
Close launcher.
Start launcher.
Open preference… again and see if the tick is still there.

Then please kindly let me know. :smile:

I can verify that the option now sticks. I am curious though now, activity monitor list about 6 different 64-bit wine preloaders while the client is running, but only one of them has major CPU usage… That was with using a single client, can’t run multiples right now to see if it gets worse.

In my case, it’s the 32 bit option that isn’t persisted. I need to run in 32 mode because of client freeze when entering warp, but I need to uncheck the 64 bit option each time I start the launcher.

I just submitted a bug to CCP about this.

Wanted to let you know kindly that the tick is still there and the game is working again. Still in Beta mode, so do I need to change it back to release ver type? I am kindly saying thank you and hope it works for a while.

P.S. I never stepped out of the station, so I am not completely sure is is working 100%

Try warping in 64-bit. I dare you. :wink:

Should work now with latest wine 4.17, did on my imac. No issues so far.

1 Like

Works as advertised.

Thanks for getting this fixed. The 64-bit client is a much more enjoyable experience than the 32.

Followed GM Mechanic’s instructions to the letter (successfully). MacOS 10.14.6, i7. 40GB RAM.

Still getting 20% session crashes at gate jumps. Sometimes the jumps take 2 to four minutes and are successful, sometimes they crash.

If this problem is now “resolved,” do I need to open a ticket? Despite what my mom told me, I’m pretty sure I’m not that special. : )

Let me know if a ticket will be helpful, please?

Thanks

Following GM M’s instructions did work for getting the client to run in 64-bit. I will report back with how the overall performance is, but going through this step by step (including making sure the client was shut down and deleting the WINE folder) was successful. On restarting the client, WINE was downloaded again (this takes several minutes to start, so don’t get worried if it looks like nothing is downloading) and then the client started without the “This application is not optimized for Mac” warning."

@OG_Halberd Just as a possible issue, are you using Dx9? I found that not using that setting and using Dx11 dramatically increased the amount of time before the client crashed on warp/gate. I’m hoping the changes to get it to 64-bit will eliminate them, we’ll see, but using Dx9 was causing it to crash a LOT on warp or gate.

OK, two days of long play sessions and lots of jumps - so far so good. I think the new WINE version did the trick. Will continue to monitor the situation, but can go 3-4 hours without crashing now.