How to configure the launcher for 64 bit version, How to configure the launcher for 32 bit version

The 64 bit version of the launcher requires wine-4.17-Staging-whinehq-binary-208 to work. If you run the 64 bit client while having wine-1.9.17-143-g91037ca-ccp-master-72 you will get an error stating that a file is missing from your bin folder. This is because the older wine version can only run 32 bit applications.

To configure the launcher for 64 bit version please do the following.

  • Start launcher
  • Click on EVE launcher in the apple menu at the top of the screen
  • Select preferences.
  • Make sure Run clients with 64 bit is ticked.
  • Make sure wine version is set to latest
  • Click ok

To configure the launcher for 32 bit version please do the following.

  • Start launcher
  • Click on EVE launcher in the apple menu at the top of the screen
  • Select preferences.
  • Make sure Run clients with 64 bit is NOT ticked.
  • Make sure wine version is set to wine-1.9.17-143-g91037ca-ccp-master-72
  • Click ok

If you are trying to run the 64 bit version and your wine version is set to latest and the client is not starting then you may be encountering a bug where the latest is not updating automatically to the latest wine-4.17-Staging-whinehq-binary-208, if that is the case simply click on latest and change it to wine-4.17-Staging-whinehq-binary-208 and then click ok to close the preference window. The open preference again and switch back to latest so that you get future updates to wine automatically.

Post updated with latest data.

2 Likes

Hello,
This definitely resolved launching the client. However, regardless of using the 32 or 64 bit client, I am still unable to use the command key and the mouse to do a right click. Will this be addressed soon? it’s kind of hard/impossible to do some actions without the right click function.

Thanks,
Odama III

1 Like

Hi Odama III

The reason you were able to use those shortcuts was because we added something called CCP-master which mimicked the Windows or PC behavior. Unfortunately ccp-master was causing a conflict with the 64 bit client and therefore we had to remove it. I’m not aware of any plans to address this at this time.

Ouch, so no more right clicks for MAC users? :frowning:
Is there a workaround at all?

Workaround would be to not use a Magic mouse and instead use a mouse with two buttons. And there might be some other tricks you can use that some Advanced Mac users might know, but I’ve not researched those yet.

2 Likes

I would try clearing your client side cache.

Hi GM Mechanic, I followed the configuration for 64 bit due to the freezing issue and set the latest to wine-4.15-Staging-whinehq-binary-207, but client is not starting anyway.

1 Like

FWIW, in trying to work around the client freeze problems that started after 2019-09-12 DT, I’ve found the instructions given here to switch between 32-bit and 64-bit modes problematic.

In particular, deleting the wine folder in the SharedCache as described seemed to cause the launcher to not be able to launch the client the next time it was started after having deleted that folder, and it wasn’t because of the reason given at the end of the post, or if it was, manually picking the right wine version as described didn’t fix the problem. What finally worked for me was switch between 32-bit and 64-bit modes again without deleting the wine folder.

So maybe it’s a good idea to follow the procedure and delete the wine folder as described for some reason, but if someone has problems launching the client afterwards, as happened to me, you may want to try switching between 32-bit and 64-bit modes again using the procedure described here (i.e. choosing the right wine version for each mode), but without deleting the wine folder.

Actually, I had no idea it was recommended to delete that folder when switching between 32-bit and 64-bit modes and was able to switch between modes flawlessly every time until now.

1 Like

@Knowledgeminer I get the same results, yes, but the issue of the ‘initiate warp freeze’ still persists in 64-bit even after having done all of the proposed fixes. In other words, even if you’re able to log in again with 64-bit, the warp freeze bug still happens.

Yeah, the client is still completely unplayable in 64-bit mode, I didn’t mean otherwise. I was talking about the addidional problem I encountered of not being able to even launch the client as a result of following the procedure described here in trying to work around the freezing problem. They really messed it all up big this time.

1 Like

It feels a lot like this is caused by the call that is made to generate the warp animation graphic. On a fast align ship like a tactical destroyer in prop mode or an interceptor, it happens in ~2 sec, but on a slower ship it happens at the eventual align time end.

The above solution does not have anything to do with the 64 bit client freeze issue. It only helps with the issue were players are getting Client launch failure error.

Only workaround for the 64bit client freeze I’ve found so far is running the 32 bit client. wine-4.15-Staging-whinehq-binary-207 should work with both 32 bit and 64 bit.

Maybe I wasn’t clear, but as I explained in a previous post, I ended up getting client launch failures I never had before precisely as a result of following that procedure. Only by omitting the deletion of the wine folder could I get the launcher (not the client) to work properly again.

It should, but you’ll still get the freezing problem in 32-bit mode if you do that. The freezes just seem to be much less frequent, you may at least fly around and play normally for some time, but eventually the client will freeze in 32-bit mode too.

I’m trying running in 32-bit mode with wine-1.9.17-143-g91037ca-ccp-master-72 now, to see what happens, which is annoying because the command key mapping for each version of wine is different, and now that I was getting used to the new mapping, I’m having to go back to get used to the old mapping again…

1 Like

One note about this; this has always been an issue with the 32-bit, and it’s why the 64-bit was so great. On 32-bit you have a built-in memory limit, and once you do enough jumps, that memory limit is reached and the client freezes or crashes. It’s usually during a gate jump. The 64-bit removed that limit (or at least it was now insanely high) and those particular crashes no longer happened.

That’s because the 32 bit client can only use 3.6GB of your computers available memory while the 64 bit client can use all available memory.

I understand the 32-bit limitations and 64-bit advantages, but FWIW I wasn’t experiencing those crashes/freezes and the client was very stable in 32-bit mode for me until now, maybe because I was running in potato mode on an old iMac.

Eventually that old computer couldn’t handle EvE anymore (for performance and compatibility, not stability, reasons), so recently I had to get a new one. I was delighted how well the new iMac could play EvE in windowed mode at 2560x1395 with max quality settings, but yeah, I’ve been running in 64-bit mode from the beginning there, so I have no idea how well 32-bit would have worked with those settings on the new computer before the recent freezes.

So 64-bit is completely unplayable now… And 32-bit with wine-1.9.17-143-g91037ca-ccp-master-72 selected just froze on me while I was typing this, not warping or jumping gate but landing this time… But that could be because of the higher than supported screen resolution and not be related to the 64-bit issue, indeed…

Oh look, I didn’t force quit it this time because was busy typing this, and it unfroze itself after a few mins… How weird…

EDIT: And a few minutes later it finally crashed without me doing anything, I was just sitting cloaked in space, but this is getting off-topic in this thread.

Yeah I think it was because of potato mode. I can run quite a while in potato before the memory is exhausted.

That sounds like you’ve used all the available ‘real’ memory, and it’s now using ‘swap’ memory on disc - which will slow things down enormously.

Yeah, sounds like that, but is not what happens. I have 40 GB of RAM on that computer, Activity Monitor doesn’t show any memory pressure, and it doesn’t look like I’m exhausting the amount of memory that can be addressed with 32 bits either.

I may try to take a closer look later, but frankly I’m getting tired of this. It worked great until Sept 12th DT, and now the game freezes or crashes too often even in 32-bit mode. Yesterday I decided to simply give up trying to play for now. Not fun at all.

  1. Not everyone is physically capable of using a mouse with 2 buttons. I imagine that EVE is actually very popular with people who can’t play more twitchy games, but still enjoy teamwork and competition.

  2. Everytime I open the launcher it resets to 64bit mode. When changing the tickbox, it should persist the next time I open it.