The game completely freezes on the Mac OS

The game completely freezes on the Mac OS when i trying to warp. It started after today’s DT.

1 Like

The highest supported resolution is 19201080, if your resolution is higher then that try lowering it to 19201080 and see if the issue persists. If it does try lowering it even more and see if the issue persists. Might be a memory issue, especially if your running the 32 bit client. The bigger the resolution the more memory the client requires.

It didn’t help, some kind of bug was probably in today’s patch. (64 bit client)

Try my Configure launcher for 64 bit guide:


Hopefully that will resolve this issue for you.

This version has been installed for more than a month. But the problems started right after DT. Which half an hour before DT was not.

Not possible, it was updated 2 days ago. The previous version that was published more then a month ago was wine-4.4-staging-xxxx, the current version is wine-4.15-Staging-xxxxx, please try switching to wine.4.15 and delete wine emulator like I explain in my post then restart and see if that does anything for you.

I meant that I already set the latest version of the fault in the settings for launching a 64-bit client, even when this opportunity appeared about a month ago. I repeated what was in your post (deleted wine), now the client does not start at all =)

LogLite last entry:

1 : blue.BlueOS: BlueOS::Startup(): InitVerificationContext failed
0 : {2148073497:Unknown} in in unknown source: CryptAcquireContext

Ah ok I misunderstood. I think that is a wine error, deleting wine and wait before clicking play. There is a bug that may allow you to start a client before it has finished downloading wine, if that occurs then the client will nuke it’s own wine install causing all kinds of weird errors like the one posted above.

1 Like

deleted the wine, install it again and waited 10 minutes before starting the game, it seemed to help =)

3 Likes

Wait, wait, something doesn’t make sense here. This is indeed a new issue that started happening after today’s DT and is by no means solved. The 64-bit client was working very well until today’s DT, but now many of us are experiencing client freezes immediately after undocking and initiating warp when in 64-bit mode, as you may see being reported in the 64-bit Mac Client, Wine, and YOU and Feedback on 64-bit Mac Client threads.

It works MUCH better in 32-bit mode, but still freezes every now and then there too, so maybe not 64-bit related and 64-bit just aggravates the problem, but something in the Mac client definitely got broken today…

1 Like

A wine update from today definitely broke something. I got the frozen screen at east FIVE times during a fleet today. Very frustrating to say the least. If I use the 64-bit version of the client and initiate warp to anything, the screen instantly freezes and I have to kill the processes. The only thing that works is running 32-bit, but even then it’s only going to last until maybe 2.5G of memory is consumed, then it crashes like it used to. 64-bit was crazy awesome until now.

Edit: small update. I have set the client to 64-bit, closed it. Then deleted the wine folder. Then restarted the client, allowed it to download the new copy of Wine. Failed. Nothing starts.

Fails with the logger output:

Unknown
CryptAquireContext
BlueOS::Startup(): InitVerificationContext failed
1 : blue.BlueOS: BlueOS::Startup() InitVerfificationContext failed.

If I rename wineenv to wineenv.hold and restart the client I’m able to log in, and the opening animation sequence runs, and overview and all settings are back to their defaults. If I then exit and rename wineenv.hold to wineenv, I’m able to login with my previous settings intact . However, if I initiate warp… freeze again.

I’m experiencing the exact same issue. It worked fine last night. I had to wait for the launcher to download something today, and now the client freezes hard if I initiate a warp.

1 Like

Yeah I have lost 2 HG pods due to this bug but “server logs show nothing”
i swapped to 32-bit and it seems to fix it but a bunch of files after the patch have been flagged by my antivirus as malware

Ok, I’ll remove the “resolved” mark and look at the situation for a couple of days. But it helped me

1 Like

Same issue here… switching back to 32 bits to see if it continues. Lots of freeze comes when “estabishing warping thing”

Macbook pro retina dual video cards
mac osx mojave

I was probably lucky yesterday that after reinstalling wine the problem disappeared for those few warp jumps that I did. Today I entered the game, the problem on the first warp jump appeared again. Indeed, yesterday after DT something was broken in the game, I had to return to the 32 bit version.

Even switching to 32bit and following instructions specific to Wine versions has not solved the problems for me. Cannot start client on either of my Macs now.

Sierra and Mojave

error 2019-09-13T11:13:21 18 C:\tq\bin\exefile.exe blue Main BlueOS::Startup(): InitVerificationContext failed
error 2019-09-13T11:13:21 18 C:\tq\bin\exefile.exe blue ERR
1 : blue.BlueOS: BlueOS::Startup(): InitVerificationContext failed
0 : {2148073497:Unknown} in in unknown source: CryptAcquireContext

Same here. I tried to go back to the 32bit client, but that one always crashes at the moment of character selection now. Might be unrelated though.

The 64bit client ran beautifully until the Wine update of 12/09. Now I get a freeze when initiating warp (with the same error message as already shared above) — except, apparently, when I’m already aligned to my warp target…

Which might point to the new “establishing warp vector” feature and the latest Wine having a conflict, but I’d still need to test more to be sure.

It’s most likely unrelated, I have now reproduce the issue with the 64 bit client freezing, so far the only workaround seems to be switching to the 32 bit client. We are aware of this issue and we are currently investigating.

3 Likes

GM Mechanic, thanks for update. If a fix is not possible soon, is there any way you could make the previous iteration of Wine available as a selection in the Wine version dropdown so that we could continue to use 64-bit?