UPDATE: Client Freeze Issues – MacOS 64-Bit Client

I was able to play in my Mac using 32 bits until before yesterday. Just updated my Mac to Catalina yesterday and now I can’t run neither 32 or 64 bits. By the way, I removed the old Launcher from Apps, downloaded from the website, reinstalled and still having the same issue.

Further to another post Elsewhere in the forums re Mac launcher fails…Whilst doing a full clean install - on to Mac OS Sierra -10.12.6…mid 2011 iMac - I also noticed that the logs showed errors with something called x11 and an Apple reference. About X11 for Mac In turn this page links to The XQuartz project . A quick download of this and restart and i appear to at least get a character to launch… I am yet to see if all is fully ok… i.e. warp, dock etc.
This has me wondering if something is missing from the bundled Eve installer or possibly a reference within that installer is incorrect or has become incorrectly referenced between development and publication.
Maybe someone can advise what The XQuartz project software adds to the launcher /installer mechanism… then advise the Eve developers how to fix for everyone if indeed this is a missing part.

It isn’t playable on my Mac. I usually run five accounts but now at least two will hang within a few minutes of starting play. I have filed a support ticket asking for my accounts to be frozen until CCP has solved this problem.

RIP eve on mac … in catering to the latest OS you are dropping support for the vast majority of mac users who will not be upgrading. also the game does not run on older hardware as of today. unsubbing my 5 accounts and moving on

Downloading and installing XQuartz fixed the hang after launch on my Mac

1 Like

Same problem. Client don’t launch on Catalina. Unsubscribing last account (3 total) unfortunately.

Had been playing EVE for a couple of weeks without any trouble. After the update on Thursday 14 November the launcher worked fine, however wine window wouldn’t start up.
Got everything working again after a full reinstallment!
Macbook Pro mid 2014, 10.15.1

Same issue with Catalina and the freezing issue becoming a real problemo.

The “wine-4.17-Staging-winehq-binary-208” seems to be a little better than latest (“wine-4.19-Staging-winehq-binary-210”) but still almost impossible to play while in space and trying to switch between windows.

Same here. I have five paid characters who have been unusable since Apple upgraded the operating system to 64 bits. CCP will need to compensate for the lost time. Actually, I’m finding myself losing interest in the game now, this is the second time I have experienced many weeks of downtime because of a CCP problem, the last was the “socket is closed” issue.

Yes, Mac OS is unplayable for multi box after Catalina upgrade. You have to choose to downgrade to previous version or to install Windows.

@McMahon_Aivoras @Stephen_Cheriton have you guys also experiencing Retina problem? Where on retina screens you not able to have eve launched in retina mode, only shitty blur old mode.

Jan 2020, it still keeps freezing. I can unfreeze it by moving the window after I select it but this is highly irritating.

1 Like

yes Jan 2020 lots of freezing lots of game crashes all crash reports are associated with translation with the 64bit part whether that is wine, game or OS it does not say. 5 times in 1 hour is just WTF and the normal is several times a day.

It is now 09-01-2020 and since this weeks patch the lag issues are to insane and quite frankly the game is not worth the cost of Omega and I am paying for 2 accounts so double annoyed.

Im paying for five accounts and have had issues with it freezing since the 64 bit upgrade. CCP tells me I am the only one. Sick to death of this unreliable POC.

Could someone from CCP please provide an update on the 64-bit Mac client issue? Is it considered resolved? If so, for what OSes and hardware configurations? I’m still running the game in 32-bit mode and experiencing crashes after a couple of hours - usually during a session change. I’ve searched through the forums and I’ve been unable to find anything definitive. If I missed it, a link would be appreciated.

1 Like

Same problem here.

MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
2,3 GHz Dual-Core Intel Core i5
16 GB 2133 MHz LPDDR3
Intel Iris Plus Graphics 640 1536 MB

Freeze client( Sometimes after 10 minutes, sometimes after 30 game started. Music stay played, but client freezes. No errors(

Freezing as soon as undocking from a station.
MacbookPro 2011 13 (i7 Model) with 16 GB RAM and Intel HD 3000.
Was working a few months before… now unplayable.

The same here.
Freezes after Catalina upgrade.
Trying to reinstall client - no luck.
I have no idea how to use wine on 64-bit OS.

I have upgraded to Catalina and since then I can not play Eve with multiple accounts. I manage to open the second account but while switching from one to other accounts freeze and from time to time crashes the Mac. I have 2018 MacBook Pro. 2.9Ghz 6-Core Intel i9,
Memory: 32GB,
Graphics: Radeon Pro 560X 4 GB
Intel UHD Graphics 630 1356 MB