New Launcher problem (1.2.8)

After today’s update launcher is not able to run properly and just show error window:

Installed in wine 8.21 with dxvk 2.3.1 and msdelta dll
Tried to reinstall to new WINEPREFIX - and found the following:
game runs only after launcher just installed and account is added. after quitting launcher and running it again getting the same error window in the new installation.

Tried to run eve-online-latest+Setup.exe in old WINEPREFIX and launcher is starting with all of my configured accounts but if I exit launcher then it won’t run again displaying same error message

I just updated to 1.2.8 and so far can not replicate your error.

Maybe try to upgrade to wine 9.1 staging. And also install vcrun2022 if you don’t have.

When the new launcher came in, i had to delete my complete wine prefix and created a new one.
I am using wine 9.1 staging with these winetricks:
winetricks corefonts msdelta vkd3d vcrun2022 dxvk2030

And i’m running the launcher from a console with the command as given by the new desktop icon.

vcrun and other winetricks’s stuff except dxvk and msdelta is not required for EVE to run - it is very well tested by me. and also if you read my starting post more carefully you can see that it was running ok before last update

Then i guess go for wine 9.1 staging…

Compiled and installed wine staging 9.1 but there is no any miracle, still getting the same error :frowning:

I tried with app-1.2.8. Even tho 1.2.7 still works for me.
With Proton, 1.2.8 and 1.2.7 works no problem.
As soon as I changed runner to anything Wine-only. Launcher would not launch, not even an error window showed up. The Play button would say Stop and then 2 secs later it said Play again in Lutris. I never use Wine anyway.
Wine-GE-8.25 and 8.26 work.
Messing around with this, I had to add Accounts again, even asked me to do so on 1.2.7. Which used to have em all. Yah, Launcher doesn’t like me changing runners, soon as I change, have to add Accounts again.
EDIT: To clarify, I mean Eve Online launcher, not Lutris, every time I mention Launcher.

tried to use lutris, because it has very convenient way to change wine versions. and found that wine-ge-8.26 and wine-ge-lol-8.27 both make it work, but at some point it also loose configured accounts, and not launcher’s config itself, it seems that messing with wine versions making launcher to loose SSO configuration. maybe it is not launcher problem and CCP’s SSO server invalidates launcher tokens because of changing client configurations

Finally I found good solution for exact problem. It seems that EVE Online’s new Launcher is written with Electron and I found similar problem on the Net where people are failing to run Electron apps. The offered solution is to run Electron apps not with wine executable but with wineconsole.
So working solution is to replace wine with wineconsole in shortcuts used to run EVE Online, that’s all! In my case changes look like this:

changed to this:

1 Like

Not experiencing that problem as i told above, but thanks for the tip, if i ever run into this problem.

I could not find conclusive info on the internet, but might the javascript engine be in the vcrun2022 runtimes that i have installed, bu you are not using?

Special thanks to Kuran SIncomil for the help and the topic!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.