New to EVE - Can't buy Plex, Omega, Packs

Hello All!

I recently got into EVE through the recommendation of a friend.
I downloaded the game through Steam, but created an account through the EVE website.
Today, I tried to buy Omega and was disappointed when I was just returned to the default.aspx.
I then tried to buy PLEX, to see if that would solve the issue, I was greeted with this screen:
I later stumbled on the packs page, and was told that I already owned them!
Is there something I need to do?
What’s happening?


1 Like

Eve servers are currently experiencing issues so you might have to wait it out and try again.

But before you do:

  • make sure you are logged on Eve’s website with account you want things on.
  • if you are trying to make purchases via Steam then all your purchases will go to the account created with that steam ID which in your case might not be the account you want.
  1. I am logged into the account which I want to purchase with
  2. I am using the EVE website to purchase things, not steam.

I’ll wait for a while and try again later.

there might problem if you are using “login with steam” on website if you haven’t set your account up properly yet:

P.S. It is always a confusion when Steam and Website get involved together.

Alright, now I’m confused.
I made an EVE account through the website
I downloaded the launcher through Steam.
I’m trying to buy things for my website account, but can’t (for whatever reason)
I’m not using my Steam EVE account at all.
Is there anything I’ve done wrong?

Nope. Servers are up - you can try shop again. If you have any problems with purchases - create a support ticket about it at:

Nothing’s changed
I’m so confused
Support Ticket submitted

I don’t know if it’s any different, but you could try downloading the Launcher directly from Eve instead.

I had exactily the same problem as you

i got the same problem 2 days old account and i can.t buy omega or plex or packs got 19 h to get the 7 $ omega time and it dosen.t work

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.