No Video on Linux

I have Installed a fresh copy of 3 different flavours of Linux. Kali, Mint Mate and Ubuntu. And whenever I run the ./evelauncher.sh command it loads the Launcher and when I start a client there is just no video, The screen is completely blank. This worked 3 Days ago perfectly fine on Mint Mate.

What version of Mint are you on ?

Mint Mate 20.1

Which drivers are you using for the GPU hardware? - that would be my first check.

Was there an update/upgrade in the time with mint mate? Which wine version?

no specific ones. so probably just the mint defaults don’t have an external graphics card installed. its internal. did work on same operating system.

apparently a 64bit wine prefix that wine tricks is reporting. wine 5.0 in winecfg

Ultimately I would love to run this in Mint Cinnamon. But have not been able to do so. Only had it working 3 days back on Mint Mate

this is my output from the terminal.
I installed the latest QT Engine stuff too

Settings path: “/home/jack/.config/CCP/EVE.conf”
Language selected based on stored settings: “en”
QObject::startTimer: Timers can only be used with threads started with QThread
[0126/215115.997642:WARNING:resource_bundle_qt.cpp(116)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/jack/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/jack/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
Path override failed for key ui::DIR_LOCALES and path ‘/home/jack/.QtWebEngineProcess’
[0126/215116.028067:WARNING:resource_bundle_qt.cpp(116)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.

when running cinnamon in a software rendering mode it actually loads with graphics. just very slow.
has to do with something in graphics settings somewhere.

The one I have is
AMD Radeon RX Vega 11

This does have a driver feeling about it - it’ll run using software rendering but not with hardware rendering.
Make sure you have the Radeon driver loaded rather than the default driver.

A very quick Google: there seems to be an issue with Mint Cinnamon identifying the right driver on laptops with Radeon chips on an Intel motherboard - selecting an Intel graphics driver rather than the correct Radeon driver.
Install the Radeon drivers and disable the old one.

Seems you have a AMD laptop as your graphics card is a AMD Radeon RX Vega 11. See which drivers are installed with synaptics or whatever you use. Usually the whole lot of xserver-xorg-video is installed out of the box, purge all the unnecessary ones and leave the xserver-xorg-video-fbdev and the xserver-xorg-video-radeon. If you want to use the proprietary driver install xserver-xorg-video-amdgpu.

Are you using the wine version which comes with EVE or the one installed from the distro or winehq? See EVElauncher settings.

hey, not even sure how to do that. when trying to install xserver-xorg-video-amdgpu I get the message “xserver-xorg-video-amdgpu is already the newest version (19.1.0-1)”

using the default one that comes with eve launcher

So I got it working finally!
I tested on Ubuntu and Mint Cinnamon.

Had to install wine separately and found the one i use is a 64 bit. Took off the DX Client 9 setting in the launcher and pointed to my own wine after installing DXVK by running
env WINEPREFIX=~/.eve/wineenv winetricks dxvk

And then I changed the cusom wine setting to
/usr/bin/wine64

Now I can enjoy my favourite Operating system with my favourite game