Only 4 of 5 accounts appear linked to email

As above, 1 account despite being on the same email and having validated that email, stubbornly doesn’t seem to be recognised when it comes to multi account sub discount.

I tried waiting as thought it was just a lag, but it’s been over 2 weeks now and still not showing (when I click the button to show accounts linked under the email from within the account that doesn’t appear to be linked it does show the 4 other accounts - so it seems partially linked, but no sub discount).

Any idea how to resolve?


Just to confirm as had a totally incorrect reply from a GM to my ticket. I have 5 accounts:

Account 1 - 90m SP main
Account 2 - c25m SP alt
Account 3 - c20m SP alt
Account 4 - c20m SP alt
Account 5 - c6m SP alt

I subbed account 1 at the max sub rate. I then subbed accounts 2, 3 and 5 at the discounted alt account rate. Account 1 is the oldest account by date created.

Account 4 is the one that isn’t showing the discounted rate i.e. this is not a case of the discount not appearing on my main.

Unbelievable! It’s actually 2 of 5 accounts that don’t get the alt account option. FML


Think I’ve figured it out, I resubbed on main using the 30 day sub pack with the 250k SP. In my account I get the 30 days sub time, but shows no subscription, so I’m thinking that’s probably why multi account discounts aren’t appearing. RIP me

EDIT: No that’s not it, still a bug.

ok found something, 1 of my accounts shows this in Account Management:


However receipts for the above account go to an old email address no longer attached to the account:


Fixed by a GM, feel free to close.


Closed per request of Op.

1 Like