People and places problem and contract search

I just tried to search Amarr in people and places and didn’t even get a response. I tried another system and I got the results immediately. I’ve heard of at least one other person recently with this same issue.

A couple of days ago, I wanted to a private item exchange contract between 2 of my characters. The recipient has a similar name to another unrelated character, so I get the dropdown choice of recipient. This time, though, I was offered no choice. The recipient defaulted to the unrelated character. This was annoying, but it was also absurd. My character and the unrelated share only a first name (mine has no last name). If anything, I would think it should default to mine with that kind of error.

Please fix.

Please make sure to submit a bug report, including screen shots and reproduction steps. While this post is helpful for letting other players know something may be wonky, there is a minuscule chance of any bug-hunting dev seeing the post - they don’t frequent the forums.