Question about installing on ubuntu 18.04


(Gisele Serebriakova) #1

Hello,

I upgraded to Ubuntu 18.04 and broke the linux launcher. At first I was trying to get the game running with dx11 and AA via a guide on here. After I gave up I uninstalled wine and wine development via the software center.

I’ve been following some of the guides you all have posted and I’ll give you want I’ve done on the last attempt.

I set up a new prefix via the instructions here:

I ran WINEPREFIX="$HOME/prefix32" WINEARCH=win32 winecfg and set the OS version to Windows XP.

I ran WINEPREFIX="$HOME/prefix32" WINEARCH=win32 wine /home/daniel/Downloads/EveLauncher-1225328.exe

The installation of the launcher appears to proceed correctly.

I ran WINEPREFIX="$HOME/prefix32" WINEARCH=win32 winetricks and ran both:

  • Select The default wineprefix -> install a Windows DLL or component -> d3dx11_43, d3dx9_43

  • Select The default wineprefix -> Install a font -> allfonts (the installation errors out and does not complete.)

I ran WINEPREFIX="$HOME/prefix32" WINEARCH=win32 wine /home/daniel/prefix32/drive_c/EVE/Launcher/evelauncher.exe -opengl

At first there was a message about a missing command related to winbind. So I ran sudo apt install winbind and installed it.

After starting the launcher again I get a popup window which says Unknown option ‘o’. The terminal reads:

daniel@uH2:~$ WINEPREFIX="$HOME/prefix32" WINEARCH=win32 wine /home/daniel/prefix32/drive_c/EVE/Launcher/evelauncher.exe -opengl
daniel@uH2:~$

Some related issues.

Last night I was trying to get dx11 working. I was following

and may have screwed up something.

After I ran into a problem with a broken script I gave up. Uninstalled wine and started over.

The command WINEPREFIX="$HOME/prefix32" WINEARCH=win32 wine --version

outputs wine-3.0 (Ubuntu 3.0-1ubuntu1)

So the version of wine I’m using in the prefix isn’t in line with the version the guides request. However, I am not sure how to create a prefix using a different version (say 3.7).


(QuakeGod) #2

Or you could run Windows and it just…works.


(Dravick Afterthought) #3

Until it decides to update itself half-way through a raid…


(QuakeGod) #4

That’s why you turn off auto updates…


(Dravick Afterthought) #5

I thought you could only do that if you were an Enterprise customer ?


(Whitehound) #6

Those two steps should not be necessary, but I don’t think they should cause any harm either.

You can further ignore the message regarding winbind, but installing it should also be of no consequence.

You don’t need the -opengl option. This is what gives you the “Unknown option ‘o’” message I suppose.

After you’ve installed the Windows launcher should you have an icon on your desktop. Check if you have something called EVE Launcher.desktop in your ~/Desktop-folder. It should look something like this:

[Desktop Entry]
Name=EVE Launcher
Exec=env __GL_THREADED_OPTIMIZATIONS=1 WINEDEBUG=-all WINEPREFIX="/home/USER/.eve" /home/USER/wine/bin/wine C:\\\\Program\\ Files\\ \\(x86\\)\\\\EVE\\\\Launcher\\\\evelauncher.exe 
Type=Application
StartupNotify=true
Path=/home/USER/.eve/dosdevices/c:/Program Files (x86)/EVE/Launcher
Icon=2E3F_evelauncher.0
StartupWMClass=evelauncher.exe
Comment=
Terminal=false

The /home/USER is your home directory. As you can see do I have my own wine version in ~/wine/bin. You’ll need to have this pointing to your own WINE installation. Also the variable __GL_THREADED_OPTIMIZATIONS=1 and WINEDEBUG=-all are my own doing. The first is for the Nvidia driver making OpenGL a little faster, the second is to turn warnings off. This just in case you don’t have a desktop icon.


(Gisele Serebriakova) #7

There is such a lanucher on the desktop.

I added in the __GL_THREADED_OPTIMIZATIONS=1 and WINEDEBUG=-all commands in the appropriate spot and removed the -opengl text at the end of the file.

Now the error I get is “The program QtWebEngineProcess.exe has encountered a serious problem…”

I’ll try following the last part of the uniwiki linux guide about getting qt running.


(Gisele Serebriakova) #8

So if I want to use a custom version of wine I have to download it, dump it in some folder, compile it, and then insert the appropriate text into the launcher/terminal when I run the evelauncher.exe? Is this the correct procedure?


(Whitehound) #9

Let’s start with the WINE version you’ve installed. Did you install wine64 or wine32?

This also seems to be a good link for you to read into:
https://linuxconfig.org/install-wine-on-ubuntu-18-04-bionic-beaver-linux

You also don’t need Qt to run the game or the launcher.

You need to know that there are two ways of starting the game. One is to use the Windows Launcher as you would use under Windows. The other is to use a launcher, which is native to Linux and can be fiddly. You decide which one you want to use.

Once you know which one you want do you need to distinguish between the guides you want to read. Some will refer to the native Linux launcher, others assume you’re going with the Windows Launcher under WINE.

The way I’m doing it is to use the Windows Launcher, which comes with the Windows installer for the game. When you have WINE 3.0 or better then you don’t need to do anything else but to set “Windows XP”-mode and that’s it. Then you can just run the Windows installer, let it create a desktop icon for you and it should all work fine with no messing about (no winetricks, no scripting, …).


(Gisele Serebriakova) #10

I installed wine via the Ubuntu Software GUI. I installed, Wine (development version) rather than just Wine. wine --version outputs wine-3.0.

I ran WINEPREFIX="$HOME/prefix32" WINEARCH=win32 wine wineboot to create the prefix per the

link given above.

I prefer the windows launcher. That seems to have longer legs than the linux based launcher snorlax released.

I’m running wine 3.0 and the OS is set to Windows XP but the eve launcher does not work out of the box.

Running the Launcher icon on the desktop gets me one of two things:

The QTWebEngine error as before.

or

A grey box. I can click on the eve E in the upper right hand corner and mess with some settings, but that’s all I can interact with.


QTWebProcess error
(Whitehound) #11

Which desktop do you use and what kind of graphics card do you have?


(Gisele Serebriakova) #12

Ubuntu 18.04. GTX 1050 ti. The NVIDIA 390 driver is installed via the software and updates GUI.


(Whitehound) #13

I’m going to assume you’re using GNOME as the desktop. I don’t know if GNOME works well or if it needs tweaking.

I can only suggest you to install Xfce4 as your desktop, because it is a good bit leaner than GNOME and games will usually give you higher frame rates with it. See if you can find it and install Xfce4 as your desktop. You should be able afterwards to switch between GNOME and Xfce4 at your desktop login.

Only for a test… Go into winecfg where you’ve set Windows XP mode, and see what it says under Libraries. You’ve mentioned that you’ve installed some extra DirectX dlls. These should have created entries in the Libraries tab. Try to set them to builtin so it uses WINE’s own dlls and to test if this didn’t screw up your set up.


(Gisele Serebriakova) #14

I had been trying to get framerates up using dx11 yesterday before I broke my old install so a different desktop could be better, yes. At the moment with the game not working at all it’s a moot issue though.


(Whitehound) #15

If I was you then I’d completely wipe the WINE directory and start over with only setting “Windows XP” mode and none of the winetricks stuff. Then directly run the EVE installer. This is known to work out of the box (except for the “Windows XP” part ofc).

Also make sure that when you install something and you don’t see a change then get rid of it again. Don’t pile up on things that may not help as these can have the reverse effect and to make things worse.

… So you did have a working game before you say? Do you remember what you did that caused the game to fail?


(Gisele Serebriakova) #16

Briefly yes. After updating to 18.04 the linux launcher broke. I created a new 32bit virtual drive (I was using playonlinux at the time.) and set it to use wine 3.7. I can’t remember exactly how I got eve working, but there was a significant performance reduction. On the old launcher I was getting 20 fps with 3 accounts running with max-ish settings, now I was at 2 fps with the same set up.

I noticed in some of the threads on this forum that some people had had success with DXVK. Seeing this might solve the problem I decided to follow:

However, at the step specified by

Building DLLs
The simple way

Inside the DXVK directory, run:

./package-release.sh master /your/target/directory --no-package

the script fails and no folders are created.

Since I saw no way to get around the problem I decided to give up.

It was around then that I noticed that my working install of eve was broken.

After that I ripped out as much of wine as I could and tried to start over.


(Whitehound) #17

You need to have mingw gcc, meson, ninja and some other stuff installed before you can build DXVK yourself. One can also simply use the binaries and install those.

I’m having difficulties estimating your skills. At first I thought you’re more or less new to Linux and that you want to install EVE. Now you’re telling me you’ve been trying to build DXVK. This leaves me with a wide gap of things that could have gone wrong. :smiley:

If you had EVE running before with an older distribution then best would be to start with a clean installation of EVE in a clean WINEPREFIX directory. You can keep your old EVE settings when you make a backup of the following directory:

$WINEPREFIX/drive_c/users/USER/Local Settings/Application Data/CCP/EVE/c_program_files_(x86)_eve_sharedcache_tq_tranquility/

You should be able to copy the directory back later and so keep all your settings in EVE.

What you then do next depends pretty much on what you did. So check that your graphics driver is working. Use “glxgears” and “glxinfo” to see if OpenGL is still working (you may have to install those tools first). A damaged OpenGL/MESA installation can easily drop your framerate to 2fps or leave you with a non-working setup entirely.

Once you get to where DX9 over OpenGL and DX11 over OpenGL is working can you try to switch to Xfce4. And from there can you start using DXVK, which with your GTX1050ti should give you two clients at 60fps under DX11 over Vulkan (DXVK).


(QuakeGod) #18

I’ve never understood why some players insist on willingly jumping through 100 different hoops and compiling a few thousand lines of code just to be able to play a game that instantly works on Windows…


(Whitehound) #19

If you know what you’re doing then it’s easy and just a good sport. Only when one thinks it’s all hoops and not worth learning then, no, it makes no sense.

I use Linux for almost everything these days and because none of it costs me a penny. It’s then nice to have EVE running under Linux, because I don’t need to switch. But I’ve got a dual-boot installation with Linux and Windows 10, and have EVE installed on both.


(Gisele Serebriakova) #20

I wasn’t worried about window settings or anything. The only thing you really need to play the game is an overview and I can get that from a chat channel in game.

Says 60 FPS repeating.

Returns OpenGL version string: 4.6.0 NVIDIA 390.48.

OpenGL should be MESA?