Reauthentication not working in launcher

The launcher told me i had to reauthenticate my accounts. I entered the password and shortly some kind of captcha window appeared and closed itself again before it asked me anything. The account stayed in unauthenticated state.

I tried several times and also restarted the launcher in between. Launcher version is 1.3.3.

The only option was to remove the accounts from the launcher and to add them again. This time a captcha window did not pop up after entering the password, but the 2FA window as expected.

Something is not working correctly. Please fix.

1 Like

Yep, getting a Session Expired; Log in.
I click “Log In” it goes to a captcha page and with in 1 second jumps me back to the character selection with the Session Expired message.

Had to do the same: remove account, re-add.

This new launcher is extremely…‘clunky’.

Getting this today too. I can’t access one of my accounts as the captcha window comes up, disappears and never lets me log the account in, I removed the account to try to re-add it, not the captcha won’t even let me add it.

Same here, captcha window comes up, disappears…
Have tried to remove accounts and everything.

It’s extremely frustrating. I cannot add my two older accounts that used the authentication from the previous launcher. I can get into my Steam account. I’ve tried uninstalling, using a new computer, pretty much everything. As of right now I am convinced CCP is against us logging in. It’s just stupid.

Same here. I can’t successfully log in. The captcha cloudflare panel disappear after one second and redirect me on login page

I’ve been having the same issue for a while now.
And today, with the Equinox launch, I went in and tried again.

Updated the game and tried to log in, but it didn’t work.
Went to Tools / Cache and clicked Removed Unused Files (just as a sanity check and to clean a bit. Tried to log in, didn’t work.

Then I sent a support ticket and received a very quick response (shout out to GM Sekizo!)
And this worked:

It’s possible that an issue with the shared cache files, used by the game, is the source of the problem. This can be resolved by verifying the integrity of the files. Please see the following instructions below:
- Start the Launcher.
- Click on the Cogwheel in the top right corner of the launcher window.
- Click on the Tools / Cache tab
- Please click on the Verify Game Files button and the verification process will begin.

After that, tried to log in again and it worked!