Ship simply moves somewhere without command

hey guys, for a while I experience a weird ingame issue.
From time to time my ship just starts moving in a random direction. Often it would break out of alignment, break anchor and move somewhere in an uncommanded way so I often get called out in fleets for doing dumb ■■■■ like this.

I thought it might be a fault with my mouse which would doubleclick in space but as I tested my mouse it actually does not produce doubleclicks. I tried to track it down and attribute to any of my inadvertant actions but failed to identify a pattern.
I also disabled keyboard shortcut for align because I thought a keystroke would cause this garbage but it did not help and now I’m totally clueless what else I can do to fix it.

Does anyone here maybe have an idea how to pin down and maybe resolve this annoying nuisence??

Are you possibly using the mouse wheel click to push to talk or something? That was the problem for me because there seems to be a binding for it.

What else can happen is when you click on a target and for a milisecond the rad context menu appears and you get there on align by mistake.

mh no it also happens when I do not talk.

Ok, the last thing that comes to my mind is a double click in the overview on a target also causes align

A common problem is that when mouse buttons start going bad, they start registering double clicks when they shouldn’t. This can result in unintentional aligns when rotating the camera. Link to a full description of the issue.

1 Like

I had this happen, even if infrequently, for many years, and in ways that cannot be achieved by accidental double clicks or other unintentional input, such as the ship starting to move “towards the screen” or straight up or down, and/or starting to move at a time when I have not interacted with the game in any way for minutes.

Far from being frequent enough to be an issue in my case, but it is an oddity nonetheless.

1 Like

I think I might have found the root cause for this annoyance and filed a bug for it.

you do realize that others cannot read your bug reports right? Linking it does nothing for others to see.

ok I didn’t know this.
Here is the text:

I’ve had this annoying issue for a while, that my ship would randomly, from times to times start moving somewhere and leave its place where it was supposed to be.

It took me a while to track it down and figured out it was the “All Drones: reutrn to drone bay” keybind that was for some reason problematic. It was mapped to key “D” at the time, which is per default “jump/dock”. After remapping drone retract to a different key, the issue of my ship randomly breaking anchor was resolved.

Looks like there is some issue with key D to be remapped to other functions. Maybe the key is somehow still registered somewhere for a function, that it should not be after assigning it a different function.

I tried to reset all settings in an attempt to fix the issue, which did not help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.