Testing Result for Beta EVE Launcher

it works

I just confirmed the patch submitted upstream works fine after today’s update without needing to move the launchdarkly library. Wine is notoriously difficult to get patches merged but hopefully it will land in time for 6.20.

4 Likes

You can just change auth to 444 and launcher wont delete it :wink:

3 Likes

Can you guys post on WineHQ Bugzilla – Bug 51821 – EVE Online Client Crashes Due to differences in how Wine and Windows handle LoadLibraryExW Undefined Behavior to say you’re affected by this? It may help get it confirmed/prioritized but I’m not sure how that usually works

2 Likes

Trying to see where to actually copy the file to make this work. I start the launcher (which loads fine) then copy the file, then try to start one of my accounts. The source file (for me) is here:

~/.eve/wineenv/drive_c/tq/bin64/packages/launchdarkly/client/launchdarkly_client.pyd

I’ve tried copying it in each of the subdirectories before launching an account but nothing ever happens:

~/.eve/wineenv/drive_c/tq/bin64/packages/launchdarkly/client/
~/.eve/wineenv/drive_c/tq/bin64/packages/launchdarkly/
~/.eve/wineenv/drive_c/tq/bin64/packages/
~/.eve/wineenv/drive_c/tq/bin64/
~/.eve/wineenv/drive_c/tq/
2 Likes

Fantastic work finding a workaround, and in good time before this hit the main client.

However, I can’t get it to work either. I start the launcher as usual from Steam (using Proton-6.15-GE-2) and then copied the file from

~/.local/share/Steam/steamapps/common/Eve Online/SharedCache/tq/bin64/launchdarkly_client.pyd

to

~/.local/share/Steam/steamapps/common/Eve Online/SharedCache/launchdarkly_client.pyd

But the client still doesn’t load.

Any ideas? As you can see my pyd-file is located in ../steamapps/common/ as I have no Eve files in ../steamapps/compatdata/ like most other people seem to, but I’m not sure why and if it has anything to do with the fix not working for me.

1 Like

it should be ~/.local/share/Steam/steamapps/common/Eve Online/SharedCache/tq/launchdarkly_client.pyd … then set file permissions to 444 also

2 Likes

I think you want to copy it to ~/.local/share/Steam/steamapps/common/Eve Online/SharedCache/tq/, not ~/.local/share/Steam/steamapps/common/Eve Online/SharedCache/

1 Like

Wow, I’m an idiot :smiley: It works now, thank you so much!

1 Like

Also to me… lutris and wine staging not working anymore

Im still looking for that launch dark file but I cant find it. Will be the same if I have it on steam or the linux launcher install?

Update: I Found the file on my other failed lutris install that I stopped using, decided to copy to my home folder and bookmarked the TQ folder on the lutris install Im using. So, I did the copy after bringing up the launcher, and it worked, but the window opened in a res that is not the usual I normally get, so maybe this little thing we are copying has inside the usual window size (for me 1024x700), but this time, it went half the wide but almost full 1080 height.

1 Like

I ended up using find: find ~ -name launchdarkly_client.pyd

1 Like

For me on ubuntu 20.04.03 LTS, steam client with proton 5.0-10 this worked like a charm:

cd ~/.local/share/Steam/steamapps/common/Eve\ Online/SharedCache/tq/bin64
cp launchdarkly_client.pyd ../

Another interesting oddity… when copying this launchdarkly_client.pyd from my other lutris install… it allows me to resize windows lol, which I havent been able to do for weeks lol. But when I return it wont remember them. I’m also noticing that the pyd file gets deleted if you login, if you close the login window the file remains in place.

What was the command to change the thing to 444 ?

Update: Lets me resize the client, but it wont remember the window size next time, so that means I’ll have to resize the window every time. I guess in the grand scheme of things its a minor problem.

Sincerest thanks to all those here that have put good work into keeping Eve running through Wine.
I’m still running using an old launcher - the recent move of launchdarkly_client.pyd was needed after today’s updates, but once in /tq rather than /tq/bin64 it still launches happily.

If we ever meet in real life then I’ll be buying the beers - hopefully you have a good capacity.

1 Like

The command is (assuming you’re in the same directory as the file):

chmod 444 launchdarkly_client.pyd

2 Likes

Worked great for me thank you. I am running Manjaro with Lutris and wine-staging 6.16 as a runner. I changed permissions on the file so that the owner can only read it. This keeps it from being deleted.

Ironically enough, the old Linux (wine wrapper) client works fine.

Thank you so much! Clients would not start after TQ patch today, came here to see if anyone had an answer. Used the temporary workaround that you suggest and will keep an eye out for wine patch.

Arch Linux
linux 5.14.11.arch1-1
wine-staging 6.16-1 + cp launchdarkly_client.pyd … workaround

On linux mint cinnamon 5.0.5, it worked well with proton 5.0-10, took me a while to realize you had to run these while in the client. thanks!

I just wanted to add my thanks for this workaround.
It runs perfect even with vanilla wine 6.18 after having done a sudo chmod 444 launchdarkly_client.pyd in SharedCache/tq as mentioned a few times above.

1 Like

I am on Arch Linux. I would like a PKGBILD please.