Thousands/decimal separator as square


I haven’t played since last August/September and I’m logging in again today to see that the thousands and decimal separator is a square instead of a space/comma (French locale). I have always played in English since 2007 and I never had this problem.

I tried changing the game to French, but the problem is still there.

I haven’t change anything to my PC or game settings (W11 with latest updates).

Is there a way to have the space back as separator and comma as decimal separator? (and no, I don’t want to change the separator in the regional settings of Windows, it will impact all my apps, such as Word, Excel, etc.)


Check pc settings

EVE takes your windows system settings for the decimals and thousands separator.

This isn’t the first time someone has your problem, the poster in this other thread seems to have had the same issue with squares as thousands separator:

All my settings are correct, always has been French locale. I even reset everything to defaults and rebooted multiple times.
I tried to change the separator as comma and it works, but every other application is messed up.

Only Eve has this separator problem. Word, Excel, Firefox, Chrome, Pyfa, jEveassets work just fine, even other games (WoW, TPF2, D3/4, etc.)

Its connected directly to the pc settings

Please refrain to comment if you are repeating the same thing.

I just said every other application/game work just fine, the problem is with Eve.

After checking, decimal separator is OK, only thousands separator is a square.

I’ll try removing completely EVE and reinstall.

If reinstalling EVE doesn’t fix it, please do try changing your pc settings, if only to see whether it fixes EVE. You can always swap back to your previous windows settings if you want.

I already tried to change the settings.

Putting a comma works (it messes with other apps), but going back to space separator make the square appear again.

Reinstalling and removing all the EVEOnline folders (C:, AppData, Local, etc.) did nothing, problem still present.

What is weird is it kept all my settings (window position, shortcuts, etc.).
Are the settings not stores locally anymore? Or are there other folders that I didn’t find?

I solved my problem, finally!

I had to edit the regional settings directtly in the registry (HKEY_CURRENT_USER\Control Panel\International) and edit the 2 keys “sMonThousandSep” and “sThousand”, deleting the old values (there was already a space) and adding a “space” then proceeding with a reboot.


Glad you found it!

1 Like


In fact, the problem seems to come from EVE Online, which can’t interpret certain types of space.

The thousands separator on Windows 11 is a U+202F (Narrow No-break Space), smaller than a standard space U+0020 (Space).


By doing what you’ve done, it ultimately comes down to changing the thousands separator in Windows settings, you’ve simply changed the type of space.

For me, the fix is to be applied at EVE Online, which should be able to display the U+202F character in addition to the U+0020 character (which is wider). Perhaps we should open a new bug report?

Hope this helps! :slight_smile:

Sources :

Hello everyone, I’m GM Chaos and I’m the Senior Technical GM here at CCP.

The Developers are aware of this issue and I’ve started poking around to see if we can get a solution in place. This problem is not unique to EVE as several games and application have this issue as well. I’d like to propose a solution which only requires you to refresh your current settings and has worked for every ticket we’ve received so far. Please take a look at the following instructions below.

  • Press the Windows Key + R on your keyboard to open the Run window.
  • Type the following and press Enter: intl.cpl
  • Click Additional Settings… near the bottom of the window.
  • In the Digit Grouping Symbol field click the arrow to the far right to open a dropdown menu.
  • In the dropdown menu click a different symbol than the one you want.
  • Click Apply.
  • Click the arrow again in the same field to open dropdown menu and click the symbol you want.
  • Click Apply and OK to close the Customize Format window.
  • Click Apply and OK to close the Region window.
  • Launch EVE Online to see if the issue has been resolved, if not you may need to restart for the changes to take effect.

What Gilthoniel Remoko said makes sense as well, and if you’d like to read more about why only the French locale is affected, you can take a look here Mystery of The French Thousands Separator. But, the solution I wrote above doesn’t change the current grouping symbol, it simply turns it off and on again. If EVE were unable to read the current character being used by the French locale, then I’d assume the issue would still be present after the changes. I can’t say for sure why refreshing it works, and if anyone knows more about this than I do I’d love to hear it.

In any case, I’ll do my best to bring attention to the issue within CCP, so no one has to resort to registry hacks in the future.