Vertical sync does not appear to be working (Mac studio M1 Max)

Using a Mac Studio with an M1 Max chip and a monitor with a 60hz refresh rate, I am still getting an average of close to 120 FPS. While this doesn’t cause me any immediate issues, I’m concerned what would happen in a big fleet fight etc. I’d like to be able to throttle my FPS but I don’t see a way to do so that works. Incidentally, when I turn on the FPS Monitor it says “GPU: Apple M1 Max FPS Throttling: None” even though I have the vertical sync option from display and graphics on, so that’s frustrating.