Zorin OS 12.3 - Great Success!

I hope this topic will help people that are new like me and rely more on the graphic interface rather than the terminal. (Im a smart dummy, but a linux dummy still)

I’ve been using Zorin for a while now for i think it’s a good transition for former Windows users, and it’s been a blast so far. Most of the games that i play on steam are Linux ready and for the damn compatibility issues i found a way to install Office when Libre doesn’t handle well.

I tried a few times to install EVE here but due to one error or another it failed on different steps of the way and i kept it in my Windows HD along with GTA V.

Today, procrastinating other chores, i decided to give it another go.

Here is the step by step that worked for me

1 - Downloaded the https://binaries.eveonline.com/evelauncher-1104891.tar.gz as usual.
2 - Clicked on Wine at the start menu on the bottom left
3 - Navigate C:
4 - Created a folder named "EVE"  on C:
5 - Dragged the "evelauncher" folder from the downloaded file to the new "EVE" folder on C:
6 - Double clicked the evelauncher.sh

This opened the EVE login screen, and started the update and download of the required files.

After 1gb of download, the “Play” button was ready.

It took a little while to load the black screen of the game, and then some more to load the resources until the character screen, but i must say i was quite happy when it finally loaded! My ship entered the hangar, and i came here to tell the good news.

So, i hope those simple steps are helpful for those who are not quite used to linux yet but want to give it a try.


May help in something:

Zorin OS 12.3 64-Bit
16Gb RAM
Intel® Core™ i7-4790 CPU @ 3.60GHz × 8
GeForce GTX 970 (Proprietary Drivers 384.111)

Wine 3.0

I just tried this on Mint 17.3, but couldn’t get past the ‘doubleclick the evelauncher.sh’ step. It didn’t appear to do anything, and when I ran it in a terminal instead I saw the error ‘Syntax error “(” unexpected’, which is odd as there aren’t any "("s in that script. Any ideas ?

What is the name of your EVE folder? Mine is “EVE”. I read in another thread that a “space” could give this error, if you used “Eve (space) Online” try making it one word only (or just name it EVE)

The script does not begin with a shebang line, so the system executes it with /bin/sh. On Ubuntu, /bin/sh is dash, a shell designed for fast startup and execution with only standard features. When dash reaches line 68, it sees a syntax error: that parenthesis doesn’t mean anything to it in context.

Since dash (like all other shells) is an interpreter, it won’t complain until the execution reaches the problematic line. So even if the script successfully started at some point in your testing, it would have aborted once line 68 was reached.

The shebang line must be the very first thing in the file. Since you use bash features, the first line of the file must be #!/bin/bash or #!/usr/bin/env bash

If the shebang is not on the first line, it will not be respected, regardless of the shell of the root user, the SHELL variable or the -s flag. You can easily confirm this is with a simple example:

echo $offset

Running this script with sudo will raise a syntax error in recent versions of Ubuntu and Debian.

You have two options to make sure the script is interpreted by bash:

Move the shebang to the first line

Run sudo like this:

sudo bash ./script_install.sh

credits: stackoverflow

Unfortunately, that just changed the error-message :-1:

username@laptop ~/.wine/drive_c/EVE/evelauncher $ sudo bash ./evelauncher.sh./evelauncher.sh: line 14: /home/username/.wine/drive_c/EVE/evelauncher/./evelauncher: cannot execute binary file: Exec format error

It occurs to me that this is on a 32-bit laptop - is Eve 64-bit only ?

No ideia, but i found this topic, dont know if it suits you.

Did you try to execute the evelauncher (1.2mb) or evelauncher.sh (312 bytes) ?

32 Bit Launcher still on the wish list?

Thanks folks. Looks like the fact it’s 32-bit is the problem. That old laptop doesn’t actually need Eve anyway, I was only trying it out of curiosity.

Morgana, was the machine you installed on 32-bit or 64-bit ?

I have edited the intial post with my specs, i use 64-bit.

Any time mate, fly dangerously. o7

also the bash thing…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.