EVE Launcher wont start after a fresh install of 18.04


(Milo T'nank) #1

Hi all,

I just made a fresh install of Pop!_os which is based on ubuntu 18.04.
Installed wine 3.0 64bit version, installed winetricks and did all the necesarry stuff to get that running.
Then I downloaded the native launcher from Snorlax, extracted it, chmod it and double clicked evelauncher.sh, nothing happens.
When I open evelauncher.sh in terminal, I see the cursor flickering, but nothing happens, no text, nothing, just a blinking cursor.

Any clues anybody?


(Gharim Turen) #2

Please have a look at this site and this thread:

Just in short, Wine 64bit only version will not do the job. EVE Online are a 32bit application, you need 32bit support on your system enabled and your graphics drivers enabled for 32bit support too.

Just updating this post from a Live Session inside from Pop!_os 18.04. This session supports from start on 64 and 32bit also the grapics driver. Wine is full installed winetricks too and @CCP_Snorlax Launcher is running after i have the missing links to two system libraries added was my installer package automatic does.

(waiting now of my counterpart, which prefer another solution).


(Milo T'nank) #3

Hi Gharim Turen,

thanx!

In what order did you do the steps? and which versions are you using?
Do you use Pop!_os 18.04? nvidia or intel iso?
Which Wine version did you use? Did you also installed winetricks? And have you added the necessary libraries?

cheers


(Gharim Turen) #4

EVE works better in this Live session as i expected :slight_smile:

i forgot to mention which libraries this was before: libcrypto.so.1.0.0 and libssl.so.1.0.0 which are already installed in /usr/lib/x86_64-linux-gnu/
oops :smiley:
Pop!_os 18.04 nvidia iso
wine-stable and winetricks from the repo just like you did, nothing others.
Try my installer package she does the necessary steps and have Snorlax’s launcher inside


(Milo T'nank) #5

Awesome! your launcher works like a charm!


(Whitehound) #6

I saw OP mention the Linux launcher. So I waited for you to come forward. Seeing the problem is solved is there little more to say.

I’m giving you a Like for your answer, and because OP didn’t. I’m like a never-ending pain in people’s neck, ain’t I?


(Gharim Turen) #7

Some times yes :smiley:

The strange thing with the Live session was, that EVE runs better with Wine 3.0 as with Wine 3.9. Maybe some regressions in the developer version?


(Milo T'nank) #8

Gents,

do you have any tips to tweak the game for a better FPS?

With my previous game I had a FPS of 60, with all textures to the max, now I have only 30.


(Whitehound) #9

Not necessarily. Maybe WINE 3.9 is too new, nor will the lack of an official Ubuntu 18.x version for WINE on WineHQ be helping.

However, I pull WINE, gcc and a whole lot of other sources from their repositories daily and compile these whenever I see some important fixes coming in. But I’m not seeing any regressions with WINE 3.9. It’s pretty smooth sailing for a while now.


(Gharim Turen) #10

Without information about your hardware its difficult. If you can live with just run EVE with dx9 enabled which are done in the launcher settings.


(Whitehound) #11

There is a bunch of things you can do:

  • use DirectX9 instead of DirectX11
  • lower graphics settings in game
  • switch to a light-weight desktop such as Xfce4
  • disable any fancy window compositor (goes for Xfce4, too)
  • set the environment variable WINEDEBUG=-all to disable all debug information
  • for Nvidia one can set the environment variable __GL_THREADED_OPTIMIZATIONS=1 for a possible gain
  • setting “Coolbits” in xorg.conf for Nvidia to enable over-clocking for the graphics card (dangerous and especially now it’s summer [on the nothern hemisphere] not a good idea)

For DirectX11 should you try to switch to DXVK, which is still young and in development. However, it implements DirectX11 over Vulkan instead of OpenGL and provides both, an fps boost as well as a big reduction in CPU usage and power draw.

And make sure you didn’t just have the VSync setting in-game set to Interval Two, because this will force it to 30fps.


(Gharim Turen) #12

Hmm for DXVK he needs WINE 3.5 or newer… oh i forgot WINE 3.6 is in the repo named as wine-development. And then he need a newer graphics driver, Ubuntu offers only 390.48 for nvidia.
If he will fiddle with PPA’s (what he also do with Pop!_OS :wink: ) then gives a newer driver, 396.24 but inofficial. I dont know wat Valve uses for her SteamOS as DE i thought it was gnome2 or something like mate…


(Gharim Turen) #13

Uhh CoolBits :wink: … BTW you set the environment variable inside from nvidia-settings with an Application profile

Hm i am atm under windows just reboot then i post my profile settings


(Whitehound) #14

One can do it in xorg.conf too:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "255"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

(Gharim Turen) #15

Oha all enabled, crazy …

cat ~/.nv/nvidia-application-profiles-rc

{
    "rules": [
        {
            "pattern": {
                "feature": "procname",
                "matches": "prey.x86"
            },
            "profile": "idtech4app"
        },
        {
            "pattern": {
                "feature": "procname",
                "matches": "etqw-rthread.x86"
            },
            "profile": "idtech4app"
        },
        {
            "pattern": {
                "feature": "procname",
                "matches": "etqw.86"
            },
            "profile": "idtech4app"
        },
        {
            "pattern": {
                "feature": "procname",
                "matches": "quake4smp.x86"
            },
            "profile": "idtech4app"
        },
        {
            "pattern": {
                "feature": "procname",
                "matches": "quake4"
            },
            "profile": "idtech4app"
        },
        {
            "pattern": {
                "feature": "procname",
                "matches": "thedarkmod.x86"
            },
            "profile": "idtech4app"
        },
        {
            "pattern": {
                "feature": "true",
                "matches": "alwayson"
            },
            "profile": "alwaysapplies"
        }
    ],
    "profiles": [
        {
            "name": "idtech4app",
            "settings": [
                {
                    "key": "GLDoom3",
                    "value": true
                },
                {
                    "key": "GLThreadedOptimizations",
                    "value": true
                }
            ]
        },
        {
            "name": "alwaysapplies",
            "settings": [
                {
                    "key": "GLThreadedOptimizations",
                    "value": true
                }
            ]
        }
    ]
}

Hmmpf forgot a bracket


(Whitehound) #16

Not at all crazy. It enables some boxes in the Nvidia settings panel. It doesn’t do any over-clocking on its own, but you have to enter increased values into the boxes before it has an effect.

I don’t see any EVE in your profile by the way.


(Gharim Turen) #17

I know, have used Coolbits “24” in the past, the Geforce 6600GT was so f*ckin hot.
The last rule enables GL_THREADED_OPTIMIZATIONS without conditions.
No problem just make a rule for exefile.exe as procname.
You should have nvidia-settings -l executed by autostart from xfce4 or in your .xsessionrc
which enables the rules on sessionstart. I have it set in the .xsessionrc


(tutan) #18

Sorry, but i have the same issue and i don’t know if you fixed your launcher trouble or you simply installed a new launcher from that link. I would like to understand why is failing the laucher after update to 18.04


(Gharim Turen) #19

It depends what you have done. If you have Ubuntu updated from version 17.xx or earlier to 18.04
and have used Snorlax Launcher before then fails the launcher because the locations of the libraries libcrypto.so.1.0.0 and libssl.so.1.0.0 have changed between the Ubuntu versions.
If you have Ubuntu 18.04 complete new installed and Snorlax Launcher too, then he misses the two libraries complete and you must set these links manually in the launcher directory.


(tutan) #20

Thanks, you are right, i just deleted both symlinks and relinked libraries from new location, then launcher works again.
I put the exact commands i used to fix the trouble just for general information

Summary

rm ~/evelauncher/libcrypto.so ~/evelauncher/libssl.so
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 ~/evelauncher/libssl.so
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 ~/evelauncher/libcrypto.so

i assume will work for all 18.04 *buntu versions