[SOLVED] Launcher does not even start on linux


(Nightwulf Stormbringer) #1

Hey there,

since the launcher update on 20th december, the launcher refuses to start.
I use Archlinux 64bit with the unofficial launcher using wine-3.0rc2 (this is the official package on Archlinux). I have been very happy with this combination hence wine 3.0 enables DirectX 11 to work with eve.
I started the evelauncher.sh even with strace but it ends on a wait4() call without any further activity straightly after searching for the executable of the launcher:
clone(child_stack=NULL, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f410c9f4310) = 3350
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
rt_sigaction(SIGINT, {sa_handler=0x4404c0, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7f410c0728e0}, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7f410c0728e0}, 8) = 0
wait4(-1,

I could post the whole strace if that helps.

I don’t even know where the launcher stores the configuration so I could step back to the wine version delivered with the launcher…

I would be very happy for any hint you can give me.

Cheers,
Nightwulf


(Nightwulf Stormbringer) #2

Hi again,

solved it using an old post as my guide: SSL issues with launcher

Cheery,

Nightwulf


(Dil'e Mahn) #3

I ran into the same problem (Launcher not doing much of anything), but linking libssl and libcrypto into the launcher directory didn’t fix it. Now I get this message:

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
[1]    4857 abort (core dumped)  ./evelauncher

Any next suggestions?


(system) #4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.