Anyone else get eve launcher to launch on 17.04 ubuntu once then it quit working?


(hans briscoe) #1

Worked great one time. I closed it out and restarted, now it won’t open. I’m not sure what I could be doing wrong.
At first I was getting something saying “error 14: permission denied”, so I found a command to fix that, but now it is saying “/bin/sh: 0: Can’t open ./evelauncher.sh”

Any advice? I just started sing linux so anything pointing me in the right direction would be great.


(COMM4NDER) #2

how are you starting it?

First the launcher needs executable rights ie “chmod +x evelauncher.sh” or using the filemanager in permissions to tick “executable”


(hans briscoe) #3

Yes, I have been using the chmod command before trying to open and am still getting the same error. It wierd because it worked great at first. I even tried going back through the whole thread I read on how to install and use it, but no luck.

perhaps I should try it again on a clean install?


(MacGregor Orlenard) #4

made any changes to OS? Maybe some update? Or you changed permission somehow?


(hans briscoe) #5

The only thing I can think of is my wifi adapter. I was using a wired connection before. I had to change some of my wifi setings and make some modifications to the drivers to get the usb wifi to work.
Actually, here is exactly what I did:
https://askubuntu.com/questions/947648/edimax-usb-wifi-ew-7811un-not-connecting-on-17-04

Those were the only changes made, but now the launcher wont even open.


(MacGregor Orlenard) #6

Nothing that should affect eve in my opinion.


(hans briscoe) #7

Hmm…I remember I had installed wine before I downloaded eve launcher. I can’t sem to find wine anywhere now.
Do I need to be running wine to run the launcher, or does it run by itself?


(hans briscoe) #8

I think I may just do a clean install of ubuntu 17.04 since I just recently built this computer and have nothing saved yet.
Can anyone link a good/current step by step tutorial so I know I am using current instructions?

I pieced mine together by reading multipe posts and some were old, so I am thinking maybe I didn’t do the initial install right.


(MacGregor Orlenard) #9

Anything you can do wrong in installation are partitions. Everything else is so automatic that you just follow installer.


(hans briscoe) #10

Update:
I’m a complete noob. :sunglasses:

I simply needed to log on as root to open the file. Worked like a charm after that…THe whole “sudo bash” thing to log onto root threw me off, because what little experience I did have was on debian and now I am on ubuntu.


(MacGregor Orlenard) #11

Change permission and you won’t be needed to use root. It’s really stupid to use root account like normal one.


(hans briscoe) #12

Thanks, I’ll make sure I get that file changed.
If I am logged into the admin and I just open a terminal window in the GUI, to execute one command as root, then close it… I’m no longer logged in as root at that point, correct?


(MacGregor Orlenard) #13

You have 3 basic account status in Linux.

  1. Root - has access to anything and in most cases don’t need to confirm changes in system core.
  2. Normal user with root privileges - It can do thing same as root but need to use special commands and confirm them with account password (use this one for good security).
  3. Standard user - can’t do operations that need root privileges.

For daily usage chose only 2 or 3. In case 2 you can easy get root status in terminal using sudo command or su. But in second case you have root status in that terminal session. Using sudo only specific command/program has special privileges.

I think this should help. Sorry if something is confusing or with bad grammar but english is not my native.


(Merkwurkdigliebe) #14

@hans briscoe

Wrong. That terminal may now be closed, but you launched using root privileges so what you launched will continue to have those privileges until terminated (ie as you play).

IF somehow a hacker were to exploit EVE online and gain EVE’s userid, that would be root and they’d be done with the hacking part of messing with you.

This used to be a huge problem on IRC :slight_smile:

Edit /etc/sudoers and make your regular user entry look like root’s , then sudo should work fine for em.

su - gives your terminal full root, where ‘su root’ only gives you root’s id w/ out the environment variables it may have.

Good luck!

  • M

(COMM4NDER) #15

Simply just use sudo and to make eve work you need to do “sudo chmod +x” to give it executable rights.
If the file is owned by root you need to change its permissions or re-download the file as regular user.

Here are the default permissions for the root folder of EVE-Launcher
http://codepad.org/sUkwpjT5

(lsperm is an alias that i use)
alias lsperm=‘stat -c “%A %a %n” *’