1 FPS After Some Updates [FIXED!] [AND BETTER THAN EVER]

I don’t have a lot of specifics because I just munged things around and suddenly stuff worked.

I got the old Qt timer thread error message and launcher failing to start. Deleting this to cause system libxcb to be used resulted in launch with severely slow graphics, like intolerable.

Updating all my system packages, which were not that old, fixed the issue.

Client is back to a halt after reboot and downtime. I made no elective changes.

Behavior is basically about 0.2 to 0.5 FPS with GPU load fairly low. I suspect something fell back to a software render or the pipe is just so starved that the GPU is hardly doing anything. CPU load is pegged on a single core.

64-bit client runs. 32-bit client won’t launch (I uninstalled 32bit libs). Neither DX9 nor DX11 seem any different. Just horrendously slow, even from the character selection screen.

FPS back up. Another minor update. FPS back down. Every single time the launcher tries to update the client, I end up back with crawling frame rates. It’s like it’s trying to unpack a resource from disk ever frame slow. 1 FPS. Iotop shows nothing interesting. CPU is pegged on one core.

I’m the least that knows stuff around here, but you could try the CPU affinity thing with taskset and tell it to assign a core to the PID of the client. There is a current CPU usage problem, but on my end it spreads on all cores, it just uses too much cpu per client and very little of the GPU.

No idea why would it work on a single core on your system though :wink:

DX 9, many wine versions, munging system libraries, beta client, obliterating old install & trying anew… I’m pretty stuck on 1 FPS this time around.

After installing the client, I first have to delete libxcb because otherwise the launcher can’t get going. I’m getting frequent issues where the launcher doesn’t persist accounts, parallel to everything else.

I have no idea what the optimal target is for getting a stable setup without this 1 FPS issue. Should I be looking at 64 bit? Local wine override? Whenever I install wine & set the path to usr/bin/wine I get no launch. No visible error output or loglite messages.

The program was running fine for several restarts. There’s no automatic updates outside of Eve itself downloading patches. I’m just about certain that one of the recent patches re-caused the initial issue I was having.

It doesn’t matter if it looks nice or like a potato. It’s 1 FPS if even that high.

My method of re-installation has been to wipe out ~/.eve and ~/.config/CCP. Delete launcher. Untar new launcher. Any other folders I can murder to try to get back to a cleaner starting point?

I’ve obliterated the entire installation, used a custom wine, used 10 wine versions. Something happened that cause FPS to drop to < 1. It doesn’t matter if it’s playing the intro video or what. It’s always choppy / horrible / like a software rendering. Strangely the graphics can look nice, it’s just so slow no human would use it.

Someone remarked in another thread to get vkd3d working by running:

WINEPREFIX=/home/me/.eve/wineenv/ ./winetricks dxvk

On Arch linux, there is a winetricks package available. I had to switch back to using my system’s wine as a custom wine, but not only is the frame rate fast, but it’s blindingly fast and running cool. Vkd3d is pretty sweet. Probably going to blow me away by looking better than ever in a minute.

My pod has never looked so beautiful.

Now, how may I recover my overview file from my backed up wineenv? Resetting hotkeys isn’t too awful but overview settings are a bit more involved.