4k appearence on TQ and Sisi


(Threm) #1

I have switched from FullHD to 2x 4k displays, needed a bit of adjusting the UI scale but it looks great.

Imagine how astonished when I was using the test server recently. Appearently there is some High DPI upscaling going on which is totally going wrong. It messes totally up. Please check out the example picture, also nice to see at the dscan area how the fonts lose its sharpness and all the details at the station and stars. Its like everything is blurred and washed.

Even if it regains its sharpness, the idea of using a 4k is also to gain space in the client. The sisi 90% scaling wouldnt be low enough to create the same look as a tq 110%. In other words, the TQ client allows me to scale up with 125% to a level which is close to original full HD resolution. But the Sisi client which appears now to be calibrated to full hd does not allow minimize the scale down to the 4k level.

Maybe its some test server related issue. But please, dont get this alive on TQ. It would ruin the 4k approach and beside it, it renders the technical investment worthless.

Thanks for considering. At least give the option to switch it off if that is technically possible.
Regards.

Technical information to the pictures:
Both share the same graphics settings. Testserver client uses 90% UI scale, TQ client 110%.


(CCP Paradox) #2

Hi there,
I am able to reproduce the blurriness if Windows (10 for me) is set to use DPI scaling on the display and EVE starts in Windowed/Fixed Window mode. The blurriness can also be corrected by entering fullscreen, and then exiting it again. On my desktop here at CCP, I sometimes have issues with applications and their DPI scaling due to the fact I have two monitors at different DPI scales (4K at 150% scaling, and 1200p at 100%).

I would recommend disabling DPI scaling on the EVE application to resolve these issues. (These steps can also help with other applications that you experience these issues with).

You can do this by editing the properties of the EVE exefile.
In the EVE Launcher, you can open the settings menu, and view the shared cache location. This will show you the folders for the servers, Tranquility and Singularity (tq, sisi).

Right click eve.exefile and open Properties, under Compatibility you can select the DPI scaling behavior.

Further reading for Windows 7: https://technet.microsoft.com/en-us/library/ff629368.aspx
Further reading for Windows 10: https://blogs.windows.com/buildingapps/2017/04/04/high-dpi-scaling-improvements-desktop-applications-windows-10-creators-update/

Please let us know if this solves the issues with EVE.

-CCP Paradox


(Threm) #3

Thanks for your swift response and (TLDR) yes, it solved it. Thanks!

It is an interesting fact that we have here two exe of (nearly) the same program. I did not made any adjustments purposefully earlier, just started and closed the clients as always.

Considering your hints:

for 1) “if EVE starts in Windowed/Fixed Window mode.” - yes
Yes I am running them in the window mode.

for 2) "the blurriness can also be corrected by entering fullscreen, and then exiting it again. "
Yes, it worked. Probably without noticing, I switched the modes for the TQ-client quite early in the process of introducing the new displays, not being aware of any difference due to the lack for comparison.

for 3) "disabling DPI scaling on the EVE application to resolve these issues."
When I tried 2) for Sisi, the client came back from full screen without any blurr. After that, even after closing completey and rebooting, the sharp version is persistent, not knowing it is now a system or a client setting. But this behaviour makes sense considering the history on the TQ-client.

Thanks again! Regards.


(system) #4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.