Aether Wars 2 Demo

So I downloaded the client. It didn’t want to run. Tried a terminal and it just sort of scrolled and hung. Rebooted and tried again at terminal to ensure a clean environment and poof it ran.

Can’t log in yet due to token not being available yet…but I have the login screen at least.

35 minutes prior got token; invalid token. hopefully in a few minutes it will work?

I used it to log in, selected the ship, tried to “Enter battle” and then it froze. I killed the task, wanted to try again and now the token is invalid.

Please don’t tell me it was a one-time token.

You got farther than me. It finally let me in; login screen says it is letting people in groups of 1000. I dunno what I’m doing.
:slight_smile:

Update I got in…no idea what I’m doing. This rattlesnake doesn’t look anything like a rattlesnake. :slight_smile:

Shaders and stuff definitely not working on linux. This looks nothing like the screenshots in the advertisements. Pretty grey…pretty bloby.

Yeah I just finally closed it. No idea what I was doing, visuals were terrible. F1 brought up the commands…but there seems to be no command to shoot, and the harvest resources did nothing.
I get that it is a test, but leaving everything to the last 30 minutes and no guidance isn’t necessarily a winning combination. It wasn’t compelling enough to sit in.

I’m in… and I’m leaving. I only saw 5-10 other ships on the screen, yet they were rubberbanding like crazy. Worst lag I’ve ever experienced in any game so far and I have a really stable FTTH connection so it’s definitely not me.

Anyway, I’ll try a few more times, after all it’s a test so of course I can’t expect anything, but I just hope EVE never ends up like this. This makes me appreciate the live client now :wink: