AIR Career Program won't load on Linux (FIXED)

EDIT:

I had this problem while using Proton-7.0 or Proton-Experimental, but rolling back to Proton-5.0-10.0 seems to have solved it for me.


Hi,

Has anyone using Linux been able to see the AIR Career Program page? I think there is a bug / limitation of Wine that prevents it from loading.

To debug I’ve tried 2 things:
(1) Enabling Eve LogLite from the Eve launcher.
(2) Enabling Proton logging using the PROTON_LOG=1 %command% launch option from Steam.

Looking at the logs from log lite, I get an error message like:

EXCEPTION #8 logged at 04/07/22 19:38:32 : request_goals_and_progress timed out:

Formatted exception info:
TimeoutException

Common path prefix = c:/buildagent/work/d2d8a22a74178531/eve/release/release

Caught at:

/packages/bluepy/__init__.py(54) CallWrapper
/packages/uthread2/bluepyimpl.py(31) inner
/eve/client/script/ui/shared/careerPortal/message_bus/careerPortalMessenger.py(69) _send_request_and_wait_for_response

Thrown at:
/eve/client/script/ui/shared/careerPortal/message_bus/careerPortalMessenger.py(63) _send_request_and_wait_for_response
/carbon/common/stdlib/stacklesslib/util.py(247) receive
self = 

The only message I see in the Proton logs is:

fixme:nsi:ipv6_forward_enumerate_all not implemented

(though I may be missing something).

ipv6_forward_enumerate_all is a networking function that’s not implemented in the latest Wine:

Maybe there’s an alternate version of Wine somewhere that would fix this?

Relatedly: I think maybe the skill plan service is affected by the same bug, it’s never loaded for me on Linux (though it does load on Windows).

1 Like