Alt/option modifier key no longer working for keyboard shortcuts?

I can no longer activate mid-slot modules with the alt/option + function keys. They just activate the high slot (function key only) instead. When I tried to edit a shortcut and enter an alt/otpion + function key combo it only recognized the function key with no modifier.

This used to work so I’m wondering if it’s the client and others are having this issue or it’s something on my system that changed.

1 Like

The Wine CCP-master which changed how the shortcuts for Mac worked and allowed those to function as they did has been removed as it was causing issues with other features.

The alternative is to get a mouse with two buttons and connect it to your Mac while playing EVE.

I have a 3 button mouse but I’m not sure I see how that helps. The problem is that the alt/option modifier key on the keyboard doesn’t work with the client at all and mouse buttons don’t work as modifier keys.

Any keyboard shortcuts that need the alt/option modifier can’t be used and if you try you get that key combination minus alt/option which is the wrong function if it’s defined at all. That renders the default keyboard shortcut set useless. It would have to be redone completely without using that modifier key.

Well a right click usually brings up the menu which you would be unable to access using a magic mouse, that’s what I was referring to, but I see your point regarding the modifier key, unfortunately I do not have a workaround for this at this time.

Playing on the Mac I’ve not had any issues as I usually do not use the modifier key for anything. Perhaps someone else has some ideas or a workaround for these issues.

Ok. I think I found the answer here: https://bugs.winehq.org/show_bug.cgi?id=35351

This is the file: ~/Library/Application Support/Eve Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wine/settings.reg

The contents looked like this:

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Mac Driver]
“RetinaMode”=“n”

I changed it to this:

REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\Mac Driver]
“RetinaMode”=“n”
“LeftOptionIsAlt”=“y”
“RightOptionIsAlt”=“y”
“LeftCommandIsCtrl”=“y”
“RightCommandIsCtrl”=“y”

Now the option/alt keys work as alt and presumably command also works as control. I had to lock the file though because the first time I tried it reverted to the original form. My guess is the launcher generates this file based on your settings but doesn’t know about these options. Locking a file the launcher is trying to write probably isn’t the best thing to do but it seems to work for now. A better solution is for the launcher to be able to select these options and generate the file correctly.

1 Like

I just tried this solution (including locking the settings.reg file), but the game is still mapping Option to nothing and Control to Alt.

This is happening to my Mac currently. I actually had an issue trying to launch the game, which was “fixed” by using 32-bit launcher. However, upon reaching the docking bay, I too noticed this issue. Ironically, I am able to relaunch in 64-bit mode but the command key and option/alt key still do not work as they did before my launcher/login issue.

If I could play on a PC, I would, as I’m sure this wouldn’t be an issue.

I would like my modifier key functions back. It is faster and allows two handed play. Also, as a new player I made an effort to learn function and modifier keys to reduce my dependency on the mouse thus permitting more efficient game play.

I haven’t been playing EVE Online on a regular basis in some time. I’d like to get back into playing regularly, again, but THIS issue is a blocker.

Using Command as though it were alt is NOT an option because this causes conflicts with Mac OS keyboard shortcuts. For example, in the new scheme, “Toggle Overload on Mid Slot 3” is Shift-Command-3 (which becomes Shift-Alt-3 in EVE Online logic). But, Shift-Command-3 is intercepted by Mac OSX as “Take Screenshot”.

I’d really like to have Alt be Alt and Command be nothing, please.

After upgrading to Mac OS Catalina, the ALT button stopped working. It seems strange, because before that everything was all right. Is this really impossible to fix?

Are you sure? Have you checked that’s really what happens in the particular case you mention here? I have those shortcuts activated in the Keyboard preference panel and they do not interfere with EvE at all, but it could be because of some other configuration change I also did because of some other interference like that, and I cannot remember what it was right now…

I’ve found this cmd/alt key thing to be an inconvenience, but no big deal in practice, for me at least, YMMV.

EDIT: Just checked, and one thing I did was disable all the ^Fn (i.e. ctrl+Fn) shortcuts in the Keyboard category of the Keyboard preference panel, because those, and ^F1 in particular, were indeed a problem.

I also do not activate the modules after updating the mac OS. And your method does not work.

My method? Which method? The Alt key not being recognised by the 64-bit version of WINE is working as intended. I didn’t reply to your post nor suggest anything to “fix” your problem. That was announced was going to happen and was discussed months ago in this other thread:

64-bit Mac Client, Wine, and YOU

ok sorry) I apparently misunderstood you. Just with this problem I ran into just now. Thanks for the link

This is still not fixed