Mouse/keyboard problems when Eve client gets input focus

When I switch to Eve (CMD+tab) from another app, about 50% of the time the Eve client gets… confused. By confused, I mean things like:

  • mouse selection does not work properly (e.g. long-clicking on wormhole does not open menu)
  • mouse drags only register for maybe 20 pixels. Like if you click & drag in space to rotate the camera view, it will rotate for perhaps 20 pixels, but no more than that.
  • the keyboard acts as if I am holding down a key modifier (shift, control, alt, etc.) So if I start typing some text, suddenly menu items are opening left and right, causing all kinds of havoc, because Eve thinks I am typing “CTRL+a” or whatever, when I have only typed “a”.

This confused state is fixed by CMD+tabbing out of the app, and back in. It happens so frequently that it is now part of my muscle memory- basically every time I switch to Eve, I do a test click to see what state it’s in, and if it’s “confused”, I tab away, then tab back. Extremely frustrating. I’ve had my char die due to this bug (CCP did comp me, to their credit.)

I do play in Windowed mode, but as far as I can tell the problem also happens in full-screen mode. I’ve been playing for ~5 months now, and this problem has plagued me the entire time, and across different (Mac) computers. I had been hoping the 64 bit client would address it, but so far it remains.

I have also tried resetting all command shortcuts to default, creating a new launcher profile, and installing on an entirely different Mac. Nothing has helped. I am happy to help debug this with you, if you have specific things you’d like me to try. Thanks for your time.

When they fixed this issue for the control and alt keys in 2016 they didn’t bother fixing it for the command key for mac users. The work around is to press the Command key that you used to switch applications again and release it. Then everything will work fine.

If I were to guess it’s that wine isn’t handling key up events properly if it didn’t see the original key down, which it wouldn’t if it wasn’t the foreground application at that time.

For the record it annoys the hell of of me too.


It’s such a relief to hear that Leto. I was beginning to think it was a problem unique to me because I saw no one else complaining about it.

And thank you for the suggestion to tap the CMD key- that is indeed a much better workaround than changing window focus.

Trying this approach for a day has helped me understand that there is at least one other similar issue, since it is not solved by the CMD trick: sometimes the mouse gets similarly stuck, usually when I am scanning, and the UI seems to think I am manually re-positioning the probes (I think that is a CTRL+mouse operation?) When it gets into this mode, it’s almost impossible to get it out. I often have to quit the game to reset it. It seems like a similar bug to me. I’m wondering if others have run into it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.