Version 19.09 - Known Issues (Mac)


Hello, everyone,

A new monthly deployment (Version 19.09) is live today. Please use this thread to monitor any official known issues that our teams are working on and to report anything you believe might not be working as intended.

Quick Info:

Other Information Threads:

1 Like

KNOWN ISSUES

Game Systems:

  • ESS Main and Reserve banks are appearing in systems other than Null security space (see comment). As of 15:15 UTC on 13 October, no new ESS should activate in unexpected locations. Any existing ESS Banks will continue operating until the next downtime.

Market:

  • NPCs are issuing sell orders instead of buy orders for Rogue Drone Infestation Data

Missions & NPCs:

  • Agency Escalations page does not load. Hotfix has been applied. Please restart all clients at your earliest convenience.

Native Mac Client:

  • Fitting window panels do not slide in/out and instead appear/disappear when clicked on macOS Big Sur.
  • Market groups do not sort correctly in Japanese, Korean, and Russian.
  • On Portuguese keyboards, Cmd+ç’ also acts as a shortcut to select all text inside text fields.
  • The ‘Track Plan’ button does not display the Skill Plan until the window has been closed and reopened.
  • Rarely, face tattoos may not appear on the character model during character creation. The tattoo is still applied to the character, but isn’t visible immediately.
  • If a new player refuses the macOS privacy permissions popup when first launching the client, the player will still be able to load into game. This results in some custom settings not being saved. If you notice some settings are not being saved, goto: ‘System Preferences’ > ‘Security & Privacy’ > ‘Privacy’ tab and make sure EVE has ‘FIles & Folders’ > ‘Documents folder’ access toggled ON.
  • Macbook trackpads can be overly sensitive and may trigger a long-left-click, opening the radial context menu. If you experience this, you can increase the ‘Radial Menu Delay’ in the ‘General Settings’ > ‘Inflight’ options menu.
  • macOS 10.14 (Mojave) may experience graphical corruption on older hardware. If you encounter this, we recommend upgrading to macOS 10.15 (Catalina) or higher.

Technical:

  • Refresh rate is lowered when multi-tasking back into a fullscreen game client. This is most noticeable on high refresh rate monitors (such as 120 or 144hz).

User Interface:

  • On Portuguese keyboards, the ‘§’ key is not shown correctly when assigned as a shortcut and uses the incorrect character in text fields.

Hello! Thanks again for releasing the native client! :slight_smile:

I still have the bug where the system does not automatically switch GPU (I also installed a tool to send a notification at every switch). Should I report the bug again with the ingame tool?

Sorry to hear that. Sending in a bug report would be the best option for the time being.

This change broke a couple short cuts:

  • In the personal/corp assets view, Cmd+A/Ctrl+A don’t select all the visible assets anymore. Cmd+A works when selecting text in notes. Cmd+A seems to navigate to the first location starting with A instead.
  • In the personal/corp assets view, Cmd+C/Ctrl+C don’t copy entries anymore. Cmd+C works when copying text from notes. Cmd+C seems to navigate to the first location starting with C instead.

I filed bug report EBR-224905.

2 Likes

Not a big issue, that tool allows me to quickly select the GPU I prefer, I’ll report a bug when I can :slight_smile:

@CCP_Leonidas @CCP_Dopamine Do you have an idea (not a guarantee) on how quickly issues similar to the Cmd+C/A issue I reported usually get fixed. I noticed that this blocks a bottleneck (sending assets to Jita for sale) of my business Highsec Buyback, and I will have to inform customers if that issue persists for more than a week (running out of ISK if we can’t get new assets to Jita for sale). If you can push for that bugfix to get fixed early, I would appreciate it a lot! :slight_smile:

The defect has been logged and we’re currently aiming to fix it in one of our hotfix patches. It should be a fairly quick fix, but unfortunately I can’t make any promises about when the fix will be ready for release.

1 Like

Also, in the Wallet, the Transactions and Market Transactions tabs are non-functional.

Those screens appear to be working on our side on macOS.
In what way are they non-functional for you? If you submit a bug report (F12), include any details you have, and screenshots; we’ll investigate.

1 Like

I have a key mapping issue when trying to create shortcuts: ‘é’, ‘i’ and ‘ù’ all get mapped as ‘ù’.

I have reported it as bug EBR-225059

1 Like

Thank you for releasing the Mac client!

One issue: in PI my Temperate Planet didn’t have textures on it, the other planets looked fine.

I cannot even start the client. The launcher starts, downloads stuff, I click the “play” button next to one of my accounts, it turns into the gray “stop” button, the mouse cursor changes into this small black-white circle thingy, I get the message “Starting client for your account” but no client ever appears, and after a couple of seconds the “stop” button turns back into the “play” button again.

I am running macOS 11.6 on a MacBook Pro (13-inch, M1, 2020). I cannot spot anything in Loglite that points to an obvious error. Locating the EVE.app and running it in a terminal only prints “Error launching exefile!” and quits. What can I try next?

1 Like

Noticing a resolution lock/UI issue in Window Mode that makes the UI hard to use. When I initially switch to Window Mode, the aspect ratio lock makes the UI really really small on the built-in screen. Scaling the UI to 200% makes it visible, but certain things initially get cut off. For example, in Arnola, the system name reads only as “Arnol.” Perimeter reads as “Per.” Using click+drag to change the window size unlocks the resolution in the dropdown, then resetting to the highest res seems to be a workaround to get the text all back.

Also tried forcing a GPU switch, since the new Mac client uses the Intel graphics instead of Radeon when Automatic Graphics Switching is enabled in the Battery menu. This did not resolve the issue. But I believe it’s also an issue that Eve is using the chipset graphics instead of the high-performance GPU, even with graphics settings all turned all the way up.

Specs: 2019 MacBook Pro, 16", MacOs 11.6, Switchable Graphics: AMD Radeon Pro 5500M 4 GB vs. Intel UHD Graphics 630 1536 MB

I have filed EBR-225112 for this (including a screenshot).

Hi I had the same bug, I resolved it by deleting the launcher and redownloading from the eve website. Good luck I hope it helps you too.

Looks like the short key issues have not been fixed yet. I have opened EBR-225146 and EBR-224905.

I probably didn’t delete enough settings… I guess I’ll have to hunt for more directories used by the Launcher to store stuff. :slight_smile:

If you’re having trouble launching the game, please try verifying your shared cache.
You can do this by opening the launcher settings under: EVE Launcher (menu bar) > Preferences > Tools/Cache > Shared Cache > Verify

If this doesn’t resolve the issue, please submit a support request and we will get back to you as soon as possible.

1 Like

Deleted everything found by find ~/Library -name '*EVE*' -or -name '*CCP*' 2> /dev/null, redownloaded the launcher, identical result. Filed a support request.