Version 19.09 - Known Issues (Mac)

Do others experience that cmd A, cmd C does not work on the chat member list?

If I do cmd A, instead of selecting all members it jumps to the 1st character whose name starts with an A like if I was pressing A instead of cmd A.
Same if I do cmd C, it does not copy but behaves like if I was pressing C.

this behavior is specific to that window. cmd A and cmd C works as intended in other windows.

My issue with the Wallet window (Transactions and Market Transactions not appearing) is getting extra odd to me. On another character, those UI elements fill in just fine. I tried “Clear All Cache Files” in the client and that didn’t resolve the issue.

Being that this is affecting only my industry / market character, it’s a bit of a problem right now…

I just have an irrelevant question: why is the DirectX9 option still there in the launcher settings, and what happens if I activate it?

check if your home directory (and implicitly “~/Library/Application Support/EVE Online” folder) is on a case-sensitive filesystem or not; the game client is not compatible with case-sensitive filesystems ( …/tq/EVE.app/Contents/MacOS/EVE tries to open “build/bin64/Exefile” and fails because that file is named build/bin64/exefile instead)

budha@duckling ~ % hexdump -C Library/Application\ Support/EVE\ Online/SharedCache/tq/EVE.app/Contents/MacOS/EVE | grep -B1 Exefile
00007f80 68 46 00 00 00 e9 aa ff ff ff 62 75 69 6c 64 2f |hF…build/|
00007f90 62 69 6e 36 34 2f 45 78 65 66 69 6c 65 00 45 72 |bin64/Exefile.Er|

00017f80 e7 ff ff 17 46 00 00 00 62 75 69 6c 64 2f 62 69 |…F…build/bi|
00017f90 6e 36 34 2f 45 78 65 66 69 6c 65 00 45 72 72 6f |n64/Exefile.Erro|
budha@duckling ~ % ls -l Library/Application\ Support/EVE\ Online/SharedCache/tq/EVE.app/Contents/Resources/build/bin64/*xefile
-rwxr–r-- 1 budha staff 607984 Oct 17 00:02 Library/Application Support/EVE Online/SharedCache/tq/EVE.app/Contents/Resources/build/bin64/exefile
budha@duckling ~ %

2 Likes

Well, that explains it. :frowning:

I really hate that. If a developer produces a file named “X” why would they ever want to refer to it as “x”? :angry:

Great. Now I have to reinstall this system and lose 12 years of settings and I cannot even use the backup because you cannot restore a case-sensitive backup to a case-insensitive filesystem! :rage:

2 Likes

yes, I know it’s a pain; lucky me, I only care about my Documents / Downloads / Desktop and a few other directories which I can manually backup and restore later

what pissed me off more than this, is that I opened a bug report (EBR-225087) and it was closed without a comment or explenation :frowning:

1 Like

MacBook Pro 13 (2017)
The game freezes after 5-10 mins of playing and then crashes my complete Mac, forcing it to restart… Mostly appears after jumping through a gate. Also I experience many graphic bugs which I never had before. Cant play the game anymore.

something similar happened to me, but in my ticket request they say my disconnections arent server fault so they cannot do anything to solve my losses

yeah, manual backup is what I did yesterday; getting all the other things set back up is going to be a pain but at least EVE is running now! So far it looks great, and it seems to be not nearly the resource hug the Windows client was: my MacBook isn’t getting any warmer and I also don’t get to hear the fans anymore. :smiley:

Also suffering from this issue (previous bug reports also closed, passed off as “hackingtosh” issue :frowning:) @CCP_Habakuk

1 Like

EVE became unplayable for me because of this :disappointed:
My Mac is using case-sensitive file systems ; it is up to the developers to properly access the paths and assets.

1 Like

New client is excellent, great performance uplift.

I was having some issues with my mouse shaking my camera around. I had to set my mouse polling rate to 125Hz to (mostly) fix it.

That mouse lag appears to be a wider Big Sur issue (Mouse lag Big Sur - Apple Community) but I hadn’t noticed it besides this new client.

I’m also having mouse troubles with the Mac client. I think there are two problems.

  1. If you tab or otherwise switch back to the game from another app, you must click several times before the game reliably captures mouse input. It’s especially aggravating when trying to use a menu- sometimes the menu is drawn on the first mouse click (giving you the false impression that it’s “working”), but then the next few clicks fail to activate any menu items. I have trained myself to do a camera drag as my first UI interaction when switching back, just to make sure the mouse clicks are getting recognized.

  2. Input lag. Sometimes the mouse just jumps around when trying to do “high precision” moves like positioning scan probes or Q-clicking. It feels like the game can’t draw the basic UI elements fast enough to keep up with the mouse at times. Even just using the menu system is often kind of dicey and results in lots of mis-clicks.

Both of these problems were present for me before the switch to the native client, and I had assumed they were mostly due to Wine.

@Kathaleen mentioned a potential problem with mouse polling under Big Sur, but I don’t have mouse problems with any other app. And Eve behaved this way for me under Catalina as well.

Ok, I thought my mouse was broken but good to know others ware having the same problem. When doing the left click + drag moves, everything shakes like crazy, unplayable. Game still freezing + crashing my Mac