Native Mac Client Playtest - Known Issues


Hi all

If you’ve not seen the information about the Native Mac Client playtest, please check out the news article first as it contains important information.

To reiterate the article, if you come across a problem in the client during this playtest, Press F12 and file a bug report where possible. You’re welcome to post issues in this thread, but it will be much more difficult for us to be able to investigate them compared to using the in-game reporting tool. Please include your system information if you do this (CPU, GPU, OS version at a minimum).

Please keep this thread for bugs and issues related to the client and launcher. If you’d like to give general feedback for the Native Mac Client, please use the thread here. So we can collate feedback more easily, please keep posts on-topic for the Native Mac Client. Any off-topic posts will be removed.

Found a bug, not on this list? Please press F12 and give as much detail as possible!

1 Like

Known issues

This is not an exhaustive list, but contains some of the more disruptive issues you may encounter:

OS Support

  • We currently support macOS 10.15 (Catalina) & macOS 11 (Big Sur)

Launcher

  • The launcher responds slowly on M1 based machines. To fix, turn on hardware acceleration. New launcher installs on macOS have this enabled by default, but you will need to manually enable it if you have a previous install.

Stability

  • If you get disconnected from the server, the client might freeze and use a large amount of memory. If this happens, you will need to manually close EVE from the macOS dock
  • The game may crash when exiting

Graphical

  • The client may set all graphical settings to ‘highest’ on a GPU that is unsuited. Please lower graphical settings if you experience low FPS
  • The client may appear too dark in some situations. Client brightness can be adjusted in the ‘graphical’ tab on the right side
  • High settings on NVIDIA cards may result in problematic rendering

Sound

  • The “Connecting” sound plays twice upon selecting a character

Input, UI and Localisation

  • Changing values in number fields via scrolling doesn’t function as intended
  • Sliding animation is missing from the panels in the Fitting window
  • Incorrect sorting of market groups in Japanese, Korean and Russian
  • Default Map Browser shortcut (F11) will trigger the system macOS command and won’t open the window
  • Filter text cannot be removed with backspace from the HyperNet search
  • Character Customization categories don’t expand when the character model is clicked
  • Changing UI Scaling can sometimes lead to offset picking in the UI
  • Shortcuts in the tutorial are not adjusted to a Mac keyboard
  • The game may look blurry with a non-default display scale

General

  • You may not be able to accept a fleet invite because of broken link
2 Likes

I am still not able to create an account on Singularity Test server. Is it down or do I need to keep trying?

This was addressed elsewhere, but I am repeating it here for anyone else with this question.

It is not possible to create new accounts on the Singularity server. Account can only be copied to Singularity from Tranquillity during the ‘server mirror’ process that is done every 3-4 months. The last mirror completed on February 15, 2021, using data from earlier in that month (on or before February 12). If your EVE Online account was created on or after the mirror capture date (the previously mentioned approximate date of Feb 12), you will not be able to access the Singularity server until the next mirror.

The next mirror will probably be before the end of June. It could be in May. It could be in July. There are not fixed dates for this process; CCP does them based on their testing needs.

1 Like

Hullo again devs!

This is more an informational: turns out the Launcher isn’t actively checking OS version and will still try to launch the game (and promptly error out) - but it doesn’t tell the user that it is running into issues.

EBR-217847 filed with LogLite attached so someone can see what the launcher tried to do when loading the game client in 10.14.

Yes, I just had to try and see what happened :stuck_out_tongue:

1 Like

Hi
Thanks for this - it’s one we are aware of and is something we will look at for a future release :slight_smile:

1 Like

Can’t join fleets either through fleet finder or direct invites.

1 Like

Thanks - this one is listed in the second post and I believe is already fixed internally :slight_smile:

very nice
thank you everyone for your hard work

I’m running OS X 10.15.7 on a 2020 MBP (16 GB RAM, 2.0 GHz Quad Core Intel CPU. I’ve updated to the latest launcher and Singularity is still launching in the Wine client.

1 Like

have an issue, black screen am after auth and choosing the toon,
using mac os i heard about native and you guys did not mention i supposed to make anything from my end related, it just was down from yesterday then after installing done stuck on that black screen,

Another thing it running the file as an exe file which is so weird not showing wine version not native version

Hmmm, that’s a bit weird. Can you please confirm the launcher version? How did you check that the Wine client did start? Is your launcher installation in any way different to a standard install?

I don’t know if I have the same problem as @Kai-Alon_Deninard, but when I run the game on SiSi the name of the game app is “Exefile” (when running TQ it’s called “Wine”) and it shows as an exe in the dock (the icon like a terminal window). From what I recall yesterday I thought I was running the native app and it had an actual Eve logo in the dock.

The game version is showing as 13.05.1893215
Launcher version is 1892908

Launcher version: 1894555. (Edit: that version is for TQ. Apparently when I switch to Singularity, a new launcher version shows up: 1893215)

I know its Wine because the application name in the menu bar says “Wine” and because when I quit, the crashcatcher dialog shows up as it customarily does with the Win32 look.

As far as I know, there is nothing special about my launcher install.

How can I send you a crash report? It’s too big to paste into this forum.

File a bug report via support.eveonline.com.

1 Like

If you open two clients at the same time in window mode, you cannot even change the resolution. The button is disabled.