Anyone running multiple clients having trouble switching focus between clients?


(Adara Starkiss) #1

Back when I was originally running 15.04, I was able to alt tab between clients with minor issues, many times I solved by depressing a few times the ALT button and a single click on the chatbox or any window was enough to regain focus.

Now, on 16.04, switching between accounts is being harder than before, despite upgrading the GPU, which in theory should make my system perform better (FPS wise it is). I find that while running 2 clients, switching is a pain but not as worse as when I run 3 clients (which then is a nightmare). My prior method for switching focus is not working, nowadays… even after being able to click on the chatbox… the focus is taken back to some other client I dont know (when running 3 or more). At least with 2 I know its on the other one, but with 3 I have to continually keep alt tabbing, switch to a non-client window, back, alt alt alt, click click click… and its still not there yet.

I just wanted to know if Im the only one experiencing this, or if someone else has been experiencing this and was able to find a combination to switch focus that does work :slight_smile:

(I was originally running 4 clients for mining (booster with 3 hulks/covetors)

Anyways, thanks in advance…

PS: I hate these new forums :frowning:


(Tetractys) #2

Hi,
I’m used to have 3 clients up. No problem at all switching between them (ALT key ticking sometimes as usual).
My easy secret is: no fullscreen. Expanded windows instead and taskbar in the upper edge of the monitor.

Linux Mint 18.1 (16.04 LTS in Ubuntu terms), Cinnamon desktop, NVIDIA GTX980 with 375.66 drivers, 16 Gb ram and 4K monitor (60fps).

Hoping this will help a bit.


(guigui lechat) #3

“no fullscreen” is required to have correct behaviour.
also you want to use alt ² (the key above tab) instead of alt tab to switch to windows in same application (wine in this case)


(Ima Wreckyou) #4

I use a tiling window manager, so my clients share the same 4k screen or I can switch to them with Windows-Arrow keys. The problem with the keys come from the EVE client not getting the button release event or something. At least a couple of keys “stick” when I move the mouse to another client without releasing them first.


(Adara Starkiss) #5

Im going to try that alt2 thing. Do u run multiple accounts in full screen? I havent done it in some time, but doing alt tab with full screen clients used to be slower.

Edit: Nope, that alt2 doenst work on my case, it brings up the alt 2 window but only lists the current client. I’ll try the full screen on all 3 now. The Full screen option does capture the mouse well, but alt tabbing between them takes longer than just alt tabbing between them in fixed window. I also notice that if u have other windows open (like intel and system info for ram use for example) then it puts the eve clients on the far end of the list always. I guess I could send the other windows to another workspace… as otherwise it seems to work fine. I find that Im having less problems returning to my main client (which is not full screen).

@Ima_Wreckyou: Yes, they get stuck in fixed mode, but sometimes the mouse cursor gets stuck also on the other client, as it will not show up in the screen and when u click things will open them on that client :frowning:


(Keiku) #6

Haven’t tried as I can’t even run 2 clients but did you try placing each on separate desktop and then switch those? Reg apps do get focus when switched to via desktop select.


(Aemergin Milesios) #7

I had trouble with the same thing - alt tabbing between eve clients would almost always result in the alt key sticking. Behavior was only in eve, it was not happening anywhere else. Eventually went to some other solutions to switch workspace which have become much easier to use anyways.

If you are Gnome, look for an extension called Workspace to Dock. It is just a pager that sits in a dock. Unfortunately eve only has live preview on your current workspace. All other apps have live preview though. This extension will let you keep those other workspaces visible on screen and just click to change or use your scroll wheel (much better) to change.

Another Gnome extension lets you scroll in the panel area to change workspaces, another shows you a preview of which one you are on. With some tweaks you can name your desktops and have the name show in the panel, pretty cool.

What I have settled on is a custom setup using OpenBox as my window manager and using no desktop environment. Blazing fast, very low resource usage and lets you scroll anywhere on the desktop to flip through workspaces. I set a 1 pixel border on the left and right sides that lets me scroll from either side. I’m using Tint2 as my panel and have it configured to highlight the desktop I’m currently on in a different color.

One day if I can figure out how, I’ll release a distro centered around eve (and other multi-boxing games) that has all the libraries in place, everything configured and have some 3rd party eve apps pre-installed (EveMon, Pyfa, etc.) I’m working on it right now, just need to figure out how to release it.

Hope some of these tips help anyone having those alt tab issues or just want to try something new for multi-boxing.

o7


(Elegbara) #8

I’m using a tiling window manager (xmonad) and fullscreen and I move different clients to different workspaces. Switching between clients is switching between workspaces.

Example: on workspace 1 I launch the launcher, then launch a client. When it’s up, I send it to workspace 2 with win+shift+2. After that I can again see the launcher and can launch another client.

I believe I could even use multiple displays this way.


(Adria Eqviis) #9

Also have this problem, modifier keys (Alt, Shift, Ctrl) frequently get stuck when focusing another window (which in my case is by mouse focus, i.e. I just move the mouse to another window—no clicking, no keyboard keypress.)

Best way I’ve found to reproduce this is:

  1. configure window manager for mouse focus (e.g. cinnamon/gnome: settings -> windows -> behaviour -> window focus mode “sloppy”)
  2. start 2 EVE clients, select chat window or some input box on each
  3. press (and hold!) Shift+A in first client
  4. move mouse to second client. bug #1: second client inputs lowercase ‘a’
  5. release keys
  6. move mouse to first client.
  7. press A (no shift). bug #2: first client inputs uppercase ‘A’ even though shift is no longer pressed

Hitting all modifier keys solves this, but it’s quite annoying tbfh. Unfortunately this might be somewhat buried of a bug, somewhere along the X11 -> Wine -> EVE keyboard event handling chain… still, if CCP fixes one bug for Linux, I think this is the one to try…

(@CCP_Falcon maybe a strategically placed force-release of modifiers on WM_KILLFOCUS?)

(Addendum: mouse focus is the extreme case here, but I’m pretty sure this is the same issue as stuck Alt on Alt+Tab.)


(Algathas) #10

I have also noticed this as wellon KDE. I don’t need to alt-tab usually because I have 2 large screens, however if I have one window focused and do a CTRL+Click for example in another, sometimes the mouse pointer will become a + and allow me to drag a multi select square. When it gets stuck in this mode, I can’t activate any modules, chat, or anything until I go back to the offending window, focus it, and CTRL+Click on it.


(Red Kadorri) #11

Playing eve in many windows I got used to fast clicking all modkeys.
I also have a problem with mouse clicking: context menu won’t show up after rmk. I connect it with me using mouse4 as pushtotalk button. For some reason I have to keep it pressed in order to actually open menu with mouse click.