Sticky Ctrl, Alt, Shift, Tab keys when switching between multiple EVE clients (Proton 5.0-9)

Running the EVE Client through Steam using Proton (5.0-9). Usually not too bad performance wise, however when switching between two clients, either using Alt-Tab or simply clicking into the other client, sometimes some of the keys mentioned in the title seem “stuck”. For example, switching to the other client, mousing over things in space I get the “Look at” option as if alt is pressed when it isn’t.

To fix this when it happens, I can usually either alt-tab twice quickly, or press each of the problem keys a few times each to ensure the input is correct. However, these problems can be dangerous when flying. For example, I’ve found myself aligning in random directions when trying to dock or warp using the MWD Cloak trick, which would open me up to hostile actions.

Has anyone experienced these issues, and found a better way to prevent them from happening? For further info, I play both clients in fixed window mode, and I am running Ubuntu 18.04

It’s been a long known problem, and there was a solution posted below… if you fancy checking… I personally tried that fix and reduced the problem but kept happening. I upgraded system and I went with Lutris this time, and since I went with Lutris, (and I run 4 accounts) Alt Tabbing has not been an issue, and not even clicking on the clients to switch.

Everytime I try the native launcher… I forget about this and I get greeted with that ALT key stuck and that’s a nice reminder to logoff and return to running the game thru Lutris.


Hi Rykar Rin,

it seems that it’s better to use the “switch between windows from the same application” shortcut. according to this site it’s under alt + ` (the key above tab for most english keyboards) for ubuntu. If you use xfce4, it would be super + tab as default though (super is the linux name for the windows key). This was also described in this comment. If you should “get stuck” though, the approach described in this other comment worked for me too.

I also tried EVE-O Preview. The preview part worked in compatibility mode but the client switching didn’t properly. I described that in the comments there too. It would be nice, if you could try it too and give feedback there. More systems to test would probably help.

Yep. Did you see my answer there? I asked you to check a thing (won’t take more than 5 min).

I had this problem in any proton versions from valve. I am currently using proton-5.9-GE-8-ST without this problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.