April 2023 Beta Launcher Test Thread

I have 2 SSDs, my 120gig SSD has the old steam install that apparently seems to not updated correctly, since it looks like the evelauncher.exe only has 2.5mb in size… so I assume the reason why is not working is because it failed to download/install the new launcher. Does anyone know if anywhere in the Steam EVE install… theres maybe an older copy of the launcher so that I can try to have the new launcher update again?

My 512gb SSD is a new install with ubuntu mate 20.04… I got wine staging to work, tried the Lutris script… but is not working, and trying to install EVE stops working when it tries to download the microsoft fonts…

  1. Use old launcher, you also need use proton-7.0 branch, because 8.0 proton for old launcher broken

  2. whine in official beta launcher topic about fixing bug where steamuser detected as user with admin role. CCP don’t read this forum branch.

1 Like

The old launcher usually ask me to upgrade to the new launcher… either now or upon exit, and then the next day it doesnt work. I was using Proton 8, so I will try then Proton 7… but it will still try to upgrade to the new one… is there a way to stop it from doing it?

Will test tomorrow on my laptop with old launcher (non-steam)

I did put Steam to use Proton7 and I’m playing. The issue is when it will ask me to upgrade to the new launcher… as its either now or when I exit EVE…

Do I understand then that for now the new launcher is not working yet?

I guess workaround for now will be to uninstall and reinstall? not an easy one…

Im not sure if to omega my other 4 accounts… the main I did omega for 3 months, but my other 4 I just plex them every month. I guess I can use the 10 omega days for 10 plex… and see if this gets resolved in 10 days lol, not a bad choice.

Last version of old laucher. Some time ago i probably seen message about upgrading launcher on laptop, but it mean newer version of old launcher, not beta. Check your launcher version, this work fine (with wine-proton-7.0.6)

Mmmm interesting, I will try and check. Earlier today I switched to my old 18.04 installl… and downgraded proton on Steam to 7.0.6… and I was able to play. However, I tried to bring up the launcher now and it doesnt work, I get the CCP logo and then it stops.

I’m going to try the 22.04 install and report. BRB. Ok, on 22.04… launcher did bring up, went into about and… version is as yours, 2329653. No idea why it doesnt work again on 18.04… but so far is still working on this one.

Beta launcher still working.

WTB option to login on login screen.

Anybody playing EVE with the newer old launcher (not the new beta) and Steam with Proton8? Proton7 is working, but I remember getting less cpu usage on Proton8 :slight_smile:

As i remember, Proton8 is broken - something to do with encryption algorithms

Ah good to know, thanks. What about the experimental one… is it better than proton7?

I don’t known, because i use wine-proton on Gentoo (as installed package), so, just use v7, when new launcher will released, will be possible switch on new version.

Proton-8.0.4 was released, i’m updated, and testing on 8.0.4. Previous 8.0.3c / DX11 worked fine.

I don’t known, it was fix by CCP, or improvement in new version Proton or difference between DX11 / DX12 modes, but now i see significant decrease using video memory. On my GTX1060 with 6 GB VRAM:

  • Proton 8.0.3c / DX11 - running 3 accounts, all VRAM used, for playable i used super-potato-mode on 2 from 3 accounts
  • Proton 8.0.4 / DX12 - ~5 from 6 GB VRAM used.

From the EVE Online Discord → launcher-beta → Linux thread - here be dragons

ok, nerds, we may be in front of something bigger than just the Launcher

there is a known issue in WINE: everything in any WINEPREFIX is run by default as administrator, and (since 5.12-staging) cannot be run as regular user anymore

developers are working on a proper UAC implementation that “understands” privilege de/escalations. in the meanwhile they removed “runas.exe” from the distribution

relevant info and known issue in official bugzilla: WineHQ Bugzilla – Bug 40613 – Multiple applications require UAC implementation to run installer/app as a normal user instead of administrator (WhatsApp Desktop, Smartflix, Squirrel Installers, OneDrive)

this is an issue with anything that requires admin privs to be dropped - most notably Squirrel installer


The EVE discord has a thread: → launcher-beta → Linux thread - here be dragons

CCP Avalon and CCP Stroopwafel are active in there, I agree that being active on the forums would also be nice, since scrolling up and finding information in discord is … subpar, but at least we still have CCP devs interested in helping us :slight_smile:

1 Like

oh, need will make some raids and whine there, thank you :slight_smile:

1 Like

So then, the Beta launher… that as of now will be forced upon us in December 7… is it working?

Default wine it is not (because wine runs everything as admin).
Installing the launcher from steam works (see my other thread).
Running the launcher as non steam game seems to work with some hoops.
Lutris seems to work as well, since it handles the unelevated privileges correctly.

I tried installing via Lutris and it gave me the gripe about needing to run it as a normal user. How did you get it to work in Lutris without admin user?