April 2023 Beta Launcher Test Thread

I guess it took the game a day to see the profiles… so Im back and running. I personally dislike that new launcher… is a tad harder to tell the launcher to run 6 clients… like I used to hit the 6 play buttons and wait for the clients to show up, now I have to click on 2 accounts and hit play and then scroll down to the next pair and then again for the last pair… idiotic I think.

you can set up launcher groups - one click and launch all 6 clients at once. Have a look in the settings - you set them up there.

You can also make the launcher narrow, at a certain point the play button returns.

I’ve tried to narrow the client… but it doesnt keep the same window geometry the next time I run the game, I also put it in a corner… and the next day is front center. I will try the Group Launch later.

it stays front centre for me too - the old one used to behave itself and stayed where I put it…

Does this new/actual launcher work well with Steams Proton 8?

I remember I was having issues with Proton8 on the old one… so I was forced to use Proton7.

I’m running with Proton Experimental. The client works for me without issue, but launcher piles up temp files in SquirrelTemp dir while it’s open and seems to be using a fair bit of resources, so I wouldn’t say the launcher itself works well.

I normally close the launcher once my client is running to “fix” this, but there are a lot of cases where that isn’t optimal. The client behaves ridiculously when you have momentary DCs, for example, so you’d ideally want the launcher up to relaunch as quickly as possible for activities like incursions, running abyss or super ratting.

Updated from old launcher to new today. New launcher doesn’t load - stays on the EVE splash screen.

From related entries in console log I see only this:

0488:err:vulkan:X11DRV_vkCreateWin32SurfaceKHR Failed to allocate client window for hwnd=0x8006a
err: D3D11SwapChain: Failed to recreate surface: VK_ERROR_OUT_OF_HOST_MEMORY
err: DXGI: CreateSwapChainForHwnd: Failed to create swap chain, hr -2147467259

Figured that I should try w/o dxvk (I have separate wine prefix with EVE without DXVK, debugged something in the past), and launcher works there just fine.

Anyone has any idea what it doesn’t like?

Relevant system info: debian testing, wine 9.1 from winehq repo, latest dxvk installed via winetricks, 2 GPUs: Intel Corporation Alder Lake-P GT2 [Iris Xe Graphics] (rev 0c) and NVIDIA Corporation GA103M [GeForce RTX 3080 Ti Laptop GPU] (rev a1).

Could it happen that it attempts to launch on embedded GPU?

edit: nevermind. On fresh wine prefix with dxvk installed it works

Yes, i also needed a fresh wine-prefix for the launcher to even come up and also i had to do a complete reinstall. Would be nice to know how to avoid it…annoying, but well…it seems to run…

I agree.

I gave up debugging an already working Steam+ProtonE+oldLauncher installation for a fresh reinstall.

As expected, it runs fine (bypassing Squirrel runas woes), but forces you to reauth all the accounts.

Otoh, restoring the core_user and core_char profiles from backup (everyone has a backup of them, amirite?), works flawlessly.

I got it working by installing to a completely fresh prefix, installing the winetricks and vulkan things, and then installing using wine-staging (or wine-development? on some systems) because only that version has a patch to install as non-admin, then switched back to wine-proton and ran the launcher installer. Because it was a fresh prefix I had to do a completely new install, but I could copy all my profile settings manually from the previous wineprefix.

Now what I’d like to do is find where the old install is, so I can delete it. I’m tired of piling up redundant EVE installs every time they screw around with the installer.

Also, I hate the new launcher.