Arch Linux. Executable closes immediately upon opening

Could you please explain a bit more how you did that ? Right after i hit the play, it crashes.
My wine version shows this:
wine --version
wine-2.19 (Staging)
Thanks.

No need to go back to 2.7, the problem was introduced when upgrading from 2.8 to 2.8.1 on Sep. 16th. Just stay on 2.8 until the launcher’s wine is updated.

oh man, thanks a lot!

@Dae-Aemoz
thanks for the topic.
The fact that eve logging wrote this ‘XError BadWindow’ message with status ‘info’ I wouldn’t found it years.

No problem, glad some gurus chimed in with a fix! Still manually updating my system though. Come on Freetype!

Sorry for the late reply.

I recently performed a system update and had to manually replace freetype again.

With regard to wine, at the moment under “Settings…” in the linux launcher, I have dev versions de-selected, and am using ccp-master, wine-1.9.10-ccp-daily-16.

Now seeing the same problem on Debian 10:

fixed by installing a modified freetype 2.1.8 …

Another way to deal with this for Debian users:

wget http://snapshot.debian.org/archive/debian/20170630T215111Z/pool/main/f/freetype/libfreetype6_2.8-0.2_amd64.deb
wget http://snapshot.debian.org/archive/debian/20170630T215111Z/pool/main/f/freetype/libfreetype6_2.8-0.2_i386.deb
sudo dpkg -i libfreetype6_2.8-0.2_amd64.deb libfreetype6_2.8-0.2_i386.deb
sudo apt-mark hold libfreetype6

Remember to “unhold” the package once CCP resolves the problem on their end by updating to Wine 18+ versions.

I found this thread after I noticed this very same behavior started with Ubuntu 18.04 (bionic) yesterday.

I checked the apt logs, and sure enough the libfreetype6 packages were updated night before last (v 2.8-0.2ubuntu2 to 2.8.1-0.1ubuntu2). Guess I’ll backlevel too until theres a fix.

This is now a problem again, since the rest of Arch now crashes w/o updated freetype :frowning:

Looks like in Arch, after today’s update, doing a regression on freetype now crashes X entirely. So now downgrading both libraries is no longer safe to do and EVE won’t launch at all.

UPDATE: After installing downgrader from the AUR and using it on lib32-freetype2 and freetype2 the game now launches fine and X is still maintaining stability.

downgrader -a lib32-freetype2
downgrader -a freetype2
1 Like

I’m on Archlinux, I tried what Gellian Corde said and if I downgrade lib32-freetype2 and freetype2 the launcher doesn’t even start . If they are up to date the client closes immediatly after start. Right now i uningnored lib32-freetype2 and freetype2 from being updated and waiting for a magical update to fix it.

What’s the output you’re getting when the launcher doesn’t load at all. It sounds like there’s something else besides the libfreetype issue.

Here is what I get :
/home/vilya/evelauncher/evelauncher: symbol lookup error: /usr/lib/libharfbuzz.so.0: undefined symbol: FT_Done_MM_Var
This is actually the same issue when I downgrade them and reboot, X doesn’t start and I have this issue when rebooting.

Temp fix:

1)downgrade harfbuzz using:
sudo pacman -U /var/cache/pacman/pkg/harfbuzz-1.7.4-1-x86_64.pkg.tar

(per https://bbs.archlinux.org/viewtopic.php?id=234082)

2)restart/reboot

3)then downgrade freetype as before, see above.

Game should work again, x should start as normal.

The game works perfectly again by following Kc Decartes’ steps, thank you sir. You were the kind of magical fix I was hoping for :smiley:

1 Like

For anyone having the freetype issue and who is unable (or unwilling) to downgrade, EVE works just fine with the most recent Wine standard on archlinux (3.1 at the moment).

Assuming you already have wine installed (pacman -S wine), do the following:
(1) install winetricks ( pacman -S winetricks )
(2) create a new eve-specific win32 wineprefix by running in a terminal

export WINEARCH=win32
export WINEPREFIX=~/.evewine
winecfg

(3) in winecfg set the windows version to windows xp
(4) still in winecfg disable directx 11 by going to libraries and adding d3d11 , then modifying and disabling it
(5) use winetricks to install stuff:

winetricks corefonts d3dx9_36 vcrun2005 vcrun2008 vcrun2010 vcrun2015

(6) create a bash shell to use as the custom wine version in the launcher (to set the correct WINEPREFIX!)

echo '#!/bin/bash' > evewine.sh
echo 'WINEPREFIX=~/.evewine wine $*' >> evewine.sh
chmod +x ~/evewine.sh

(7) If you need your settings, I believe you can copy them from the ‘official’ CCP wineprefix in .eve/wineenv (possibly .eve/wineenv/drive_c/users//Local Settings/Application Data/CCP/EVE ). I have not been able to test this, however.
(8) Finally launch your already installed eve launcher, go to settings and select “use custom wine”, then enter the full path to the evewine.sh script there.

Login and play… It should just work. :sunglasses:

6 Likes

Thanks a lot for this! It works! Even the copying of settings :slight_smile:

Thanks Zone Mirendir!
I will only reiterate that I had to write the absolute path ‘/home/user/evewine.sh’ in the settings for my custom wine to be recognized. It did not understand ‘~/evewine.sh’. Hopefully this saves someone a few minutes.
Feels good to finally upgrade Freetype2 after many months, haha.

So the only thing that worked for me was downgrading freetype2, but when I do that my system doesn’t boot (real talk lol) unless I upgrade them back. Zone’s custom-wine did not work for me either sadly. Any other suggestions guys? I’m on Arch

scroll up/read my friend…

Temp fix:

1)downgrade harfbuzz using:
sudo pacman -U /var/cache/pacman/pkg/harfbuzz-1.7.4-1-x86_64.pkg.tar

(per https://bbs.archlinux.org/viewtopic.php?id=2340822)

2)restart/reboot

3)then downgrade freetype as before, see above.

Game should work again, x should start as normal.

:wink: