Arch Linux. Executable closes immediately upon opening

I run debian so probably this doesnt help anyone:

Version 3.5.15-2:    

i   libgnutls-dane0:i386                                                       - GNU TLS library - DANE security support                                              
i   libgnutls-openssl27                                                        - GNU TLS library - OpenSSL wrapper                                                    
i   libgnutls-openssl27:i386                                                   - GNU TLS library - OpenSSL wrapper                                                    
i   libgnutls28-dev:i386                                                       - GNU TLS library - development files                                                  
i   libgnutls30                                                                - GNU TLS library - main runtime library                                               
i A libgnutls30:i386                                                           - GNU TLS library - main runtime library                                               
i   libgnutlsxx28:i386    

Version 1.25.6-1:

i A libmpg123-0                                                                - MPEG layer 1/2/3 audio decoder (shared library)                                      
i A libmpg123-0:i386                                                           - MPEG layer 1/2/3 audio decoder (shared library)                                      
i   libmpg123-dev                                                              - MPEG layer 1/2/3 audio decoder (development files)                                   
i   libmpg123-dev:i386  

# Staging 2.17:
$ wine --check-libs
libcairo.so.2: /usr/lib/i386-linux-gnu/libcairo.so.2
libcapi20.so.3: /usr/lib/i386-linux-gnu/libcapi20.so.3
libcups.so.2: /usr/lib/i386-linux-gnu/libcups.so.2
libdbus-1.so.3: /lib/i386-linux-gnu/libdbus-1.so.3
libfontconfig.so.1: /usr/lib/i386-linux-gnu/libfontconfig.so.1
libfreetype.so.6: /usr/lib/i386-linux-gnu/libfreetype.so.6
libGL.so.1: /usr/lib/i386-linux-gnu/libGL.so.1
libgnutls.so.30: /usr/lib/i386-linux-gnu/libgnutls.so.30
libgobject-2.0.so.0: /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
libgsm.so.1: /usr/lib/i386-linux-gnu/libgsm.so.1
libgtk-3.so.0: /usr/lib/i386-linux-gnu/libgtk-3.so.0
libjpeg.so.62: /usr/lib/i386-linux-gnu/libjpeg.so.62
libncurses.so.5: /lib/i386-linux-gnu/libncurses.so.5
libnetapi.so: missing
libodbc.so.2: /usr/lib/i386-linux-gnu/libodbc.so.2
libOSMesa.so.8: /usr/lib/i386-linux-gnu/libOSMesa.so.8
libpcap.so.0.8: /usr/lib/i386-linux-gnu/libpcap.so.0.8
libpng16.so.16: /usr/lib/i386-linux-gnu/libpng16.so.16
libsane.so.1: /usr/lib/i386-linux-gnu/libsane.so.1
libtiff.so.5: /usr/lib/i386-linux-gnu/libtiff.so.5
libtxc_dxtn.so: /usr/lib/i386-linux-gnu/libtxc_dxtn.so
libv4l1.so.0: /usr/lib/i386-linux-gnu/libv4l1.so.0
libva.so.1: /usr/lib/i386-linux-gnu/libva.so.1
libva-drm.so.1: /usr/lib/i386-linux-gnu/libva-drm.so.1
libva-x11.so.1: /usr/lib/i386-linux-gnu/libva-x11.so.1
libX11.so.6: /usr/lib/i386-linux-gnu/libX11.so.6
libX11-xcb.so.1: /usr/lib/i386-linux-gnu/libX11-xcb.so.1
libXcomposite.so.1: /usr/lib/i386-linux-gnu/libXcomposite.so.1
libXcursor.so.1: /usr/lib/i386-linux-gnu/libXcursor.so.1
libXext.so.6: /usr/lib/i386-linux-gnu/libXext.so.6
libXi.so.6: /usr/lib/i386-linux-gnu/libXi.so.6
libXinerama.so.1: /usr/lib/i386-linux-gnu/libXinerama.so.1
libXrandr.so.2: /usr/lib/i386-linux-gnu/libXrandr.so.2
libXrender.so.1: /usr/lib/i386-linux-gnu/libXrender.so.1
libxslt.so.1: /usr/lib/i386-linux-gnu/libxslt.so.1
libXxf86vm.so.1: /usr/lib/i386-linux-gnu/libXxf86vm.so.1

The xaudio thing is probably DX11 bug, you can override the dll in winetricks… Nobody is really saying which they use so…

The pastebin is also from the client log, a couple of lines before the BadWindow error.

This issue is linked to a wine and freetype 2.8 issue. The wine bug report can be found here:
https://bugs.winehq.org/show_bug.cgi?id=43715

But since we all just want to play EVE, to fix the issue is simple:
Downgrade freetype2.8 to freetype2.7 (both lib32 and regular) :slight_smile:

If you already cleared your pkg cache, you can download the old freetype packages from here:
https://archive.archlinux.org/packages/f/freetype2/freetype2-2.7.1-2-x86_64.pkg.tar.xz

and here:

https://archive.archlinux.org/packages/l/lib32-freetype2/lib32-freetype2-2.7.1-2-x86_64.pkg.tar.xz

Install using:
sudo pacman -U lib32-freetype2-2.7.1-2-x86_64.pkg.tar.xz
sudo pacman -U freetype2-2.7.1-2-x86_64.pkg.tar.xz

Note that they will be upgraded again automatically on your next pacman -Syu if you do not take appropriate steps (see pacman guide for that).

6 Likes

You are a godsend. Thank you so much!

Confirming this worked on Manjaro (basically Arch) as well. So glad someone found a solution. I was pulling my hair out because I thought my Bumblebee/Optimus setup broke again.

Confirmed working here too. Thank you!

Jesus H Christ. This is most definitely an Arch-based issue and it’s upstream’s fault, as usual. Not gonna throw too much ■■■■ around in here, but the fine folks from the wine-gaming-nine AUR package came up with a freetype2 patch about 1-2 weeks ago to work around this, but either it got rolled back up or I lost my pacman.conf with the Ignore line in my latest /etc disaster and plain forgot. I came around here to try and make CCP my scapegoat and blame their well-intentioned-but-dogshittified “native” launcher and the Qtlibs abortion they came up with. But, pump my brakes, it was ■■■■■■■ freetype2 again.

Lets do a Kickstarter for funding to buy freetype2’s patents and organization and make sure it doesn’t become another “zlib” ■■■■ bucket long-term disaster.

Also, I was too stupid to remember the problem lay with freetype2 despite my patching it. It went into my head that it was fixed since the 2.2.8 version had the patch and I have blind faith in wine-gaming-nine and the maintainer Treenz and if it pops for upgrade I run yaourt -Syu --no-confirm on it. This is my fault, not theirs in the least. But I mention this because this issue lead to me scrubbing my entire root partition earlier, including a full rsync restore. That’s how dumb I am. Have so many issues with this linux EVE client I started blaming it, then my wine binaries.

SIgh. Long story longer, I will bear your children if you ask. The silliest fixes can be the most profound when you’re frustrated.

I’m a bit confused. It says the issue was fixed in 2.18. I guess that ‘fix’ didn’t work for EVE?

edit: Oh, is it because the launcher uses its own version of Wine, which is older?

Yep, once CCP’s wine build is updated, I imagine this problem will go away. Surely some wining to CCP for not updating their wine is allowed? :wink:

I’m surprised I didn’t find this thread earlier- I encountered this issue about a week ago, but have been busy lately and haven’t had much time to troubleshoot. EvE would launch after hitting play on the launcher and immediately crash. Once i got to the character screen but it always crashes.

So far I’ve nuked my /home/user/.eve folder and nuked wine and started from scratch and still have the same issue, but i’ll be trying the Freetype fix when I get home tonight.

Strange enough, my chromebook has had no issues. Both computers run arch. I cross-referenced the error logs but didn’t find anything particularly useful other than just a generic looking report of the crash, but have seen the xwindow-type errors before. My desktop broke after an Eve update, but I think my desktop was already running newer packages than the chromebook.

I’ll let you guys know how it goes, done mobileposting for now.

Alright- so I got the launcher to work after de-selecting the dev wine builds and selecting wine-1.9.10-ccp-daily-16 instead, in-addition to downgrading freetype

not sure why I didn’t try that earlier, but i’m glad i’m back again.

Could you please explain a bit more how you did that ? Right after i hit the play, it crashes.
My wine version shows this:
wine --version
wine-2.19 (Staging)
Thanks.

No need to go back to 2.7, the problem was introduced when upgrading from 2.8 to 2.8.1 on Sep. 16th. Just stay on 2.8 until the launcher’s wine is updated.

oh man, thanks a lot!

@Dae-Aemoz
thanks for the topic.
The fact that eve logging wrote this ‘XError BadWindow’ message with status ‘info’ I wouldn’t found it years.

No problem, glad some gurus chimed in with a fix! Still manually updating my system though. Come on Freetype!

Sorry for the late reply.

I recently performed a system update and had to manually replace freetype again.

With regard to wine, at the moment under “Settings…” in the linux launcher, I have dev versions de-selected, and am using ccp-master, wine-1.9.10-ccp-daily-16.

Now seeing the same problem on Debian 10:

fixed by installing a modified freetype 2.1.8 …

Another way to deal with this for Debian users:

wget http://snapshot.debian.org/archive/debian/20170630T215111Z/pool/main/f/freetype/libfreetype6_2.8-0.2_amd64.deb
wget http://snapshot.debian.org/archive/debian/20170630T215111Z/pool/main/f/freetype/libfreetype6_2.8-0.2_i386.deb
sudo dpkg -i libfreetype6_2.8-0.2_amd64.deb libfreetype6_2.8-0.2_i386.deb
sudo apt-mark hold libfreetype6

Remember to “unhold” the package once CCP resolves the problem on their end by updating to Wine 18+ versions.

I found this thread after I noticed this very same behavior started with Ubuntu 18.04 (bionic) yesterday.

I checked the apt logs, and sure enough the libfreetype6 packages were updated night before last (v 2.8-0.2ubuntu2 to 2.8.1-0.1ubuntu2). Guess I’ll backlevel too until theres a fix.